Deleting a MenuItem from a Menu

In REALStudio it used to be possible to delete a MenuItem from a Menu in the menu editor by selecting it and pressing the Backspace or Delete key. This seems to not be possible anymore. How does this work in Xojo now?

I just tried :

  1. create a new desktop app
  2. select MainMenuBar in Navigator
  3. Click on Menu Edit in Design area
  4. Select a Menu, like Paste
  5. Choose (Xojo’s) Menu : Edit Delete

fn+Backspace (on a Macbook pro) works for me only after selecting twice a menu

Seems you may have to click twice on a menuitem and then both the DEL or the Backspace keys can delete that menuitem. Thats on WIndows 7.



Thanks, guys. Clicking the item a second time does the trick.

I haven’t tried this on the Mac yet, but you even need to click an item twice in order to use the “Edit/Delete” menu in the Xojo IDE.

Seems like a bug to me.

I can delete the entire menu, but not an item from a menu. I have tried these tips: double-clicking, clicking twice (slowly), etc. The item is clearly “selected” but the Delete key does not work and Xojo menu Edit | Delete does not work.

Never mind. I have it now. Gray background means selected. Blue background is not. (To me, this seems backwards.)

I’m glad I came across this old thread. I thought I was going mad.

The issue still persists in 2016R3(WIN7) - workable but not very intuitive.

In 2017r3 I cannot delete a menu item in the menu editor. When it’s blue, delete and forward delete have no effect, and delete and cut in the Edit menu are disabled. When the menu name in the list is gray, the item’s name field has the focus.

Hi Julia,

I’m not sure if things have changed in 2017r3, but if they have you would expect for the better, ie. less confusing, but it doesn’t seem to be the case.

The example I’ve posted is how I got it to work (ie. delete a menu item):

In my example I have MainMenuBar shown at left, and the Menu Item I want to delete is FileExport (Appearance: Export to File…) If I toggle between the two items then check if “delete” is available, then I can delete it.

All I can say is that it certainly does not make sense and is unsatisfactory because it does seem random. I’ve had a situation where both are blue, and delete is available, but if selecting another item, then we go back to square one.

Not good enough, but once you figure out the work-around then it will work as expected.

ie. Toggle between the two, until delete is avalable - it will only take a couple of clicks.


[EDIT] this is the case for 2016r3 WIN7.
Also I would be wary about using the backspace or delete key - just go to the edit menu and select delete. (if/when available).

Thanks, Steve, it worked. The key is that you have to click on the menu itself in order to remove focus from its Name field, then Delete becomes enabled in the Edit menu.

No problems Julia, glad you sorted it out.

Just be aware that if you select another menu item then go back to your original item - things may change, and what you thought was correct now doesn’t make sense. At least for me, that’s what I found. I could not work out any consistency, rhyme nor reason.

But if you stick with toggling between the two, until delete is available - then it always works - as far as I can tell.

Hello, I’m new to xojo, and I’m unable to delete menu items using any or all of the options listed in this thread. My first start to my project was to setup menu items, and I can’t do that.

Would appreciate some help on this.


What platform, and what version of the IDE?
I’ve yet to have an issue by clicking the menu item in the designer, and pressing the physical delete/backspace key on the keyboard.

I am using Win7, and 2017r3. I tried delete and backspace both when the color what was grey and blue. I can’t even delete the whole “edit” menu.


You should be able to click on the menu in the menu editor itself and then press the delete key.

Here is some User Guide info:

I tried that as well.

Ok, I finally got it. When everyone said “menu editor” I thought it meant the virtual gui display. I just clicked on the variable editing window on the far right, and was able to get it to delete.

Why in the world can’t you right click on the entry to remove on the right, and choose delete from the popup menu? Why is everything in that menu grayed out?

Very confusing.

Thanks for the help!