Delete button in IDE not working

XOJO v22r4.1 - Windows 11
The delete button is not working in the IDE.
I select an item, and try to delete, but it does not work .
It works in XOJO v21r1.1 (momentary the version I use).
Is this a bug ?

Regards
Etienne

For some, unknown reason, they re-mapped the delete action to CTRL+BACKSPACE on windows. very strange and confusing

Thanks for the reply.
Strange indeed !

Regards

You mean “the Delete Key” from the keyboard ?

Try fn-Delete…

You may also use the Contextual Menu (right-click)… :innocent:

Yes, the delete button from the keyboard.
FN-DELETE doesn’t work on my keyboard.
Contextual Menu (right-click), ok but strange to do 2 mouse clicks instead of only the delete button as in older versions.
CTRL-BACKSPACE works too.
Once I get used to it … ok I think

Regards

Sorry: on my Mac, fn-Delete works fine (since age, it works like BACKSPACE).

Strange.

I was working on a PC laptop (forget the brand), minutes ago and I had to use fn-prntscr… to make some screen shots…
I constantly make an error using alt instead of fn (because of the key locations… I think). I do not tell you how small the prntsc… layout was (and no magnifying glass when you need one !).

Cheers…

I think it was done to fix a bug where pressing delete in code would delete a navigator item, you can change it back in edit> options> general> edit menu shortcuts.

1 Like

DELETE or BACKSPACE remove Navigator item(s)…

MacBookPro m1 / Ventura / Xojo 2022r4.1

In my applications, I use Cmd-Delete as shortcut to delete (to avoid unwanted delete done while thinking removing a character from a TextField/TextArea) items, Row in a ListBox for example (where the mistake is too easy).

Attention All

it can be modified.
Try in the IDE:
Edit
Options
General
Menu: Edit Menu Short Cuts
Edit
Find Delete and press Key Del
Uncheck Control (so you will press Del without Ctrl Key)
Press Apply and you are ready.!!!

Regards

Unless you have an external keyboard, the delete key that your MacBookPro has is actually a Delete Left key* (Backspace). If you use a keyboard with both Delete Left and Delete Right* keys, only Delete Left will remove Navigator Items.

Previous versions of Xojo allowed both Delete Left (Backspace) and Delete Right (Delete) to remove Navigator items.

Edit: * I’m not sure if the keys are called that but my extended mac keyboard both say ‘delete’ but one delete the character at left and the other the character at right

You can modify the IDE shortcut keys as described above.
I am a windows user but i think above solution will work for mac users also.

:slight_smile:

Thank you but I can’t find a way to configure the IDE shortcut to use both Backspace and Delete as before. At least for mac.

The “delete” key is the one that removes characters to the right, while the “backspace” key is the one removing characters to the left.

Thank you Arnaud, that is the way I learned while using a PC as the keyboard was labeled as such.

This is how the keyboard I’m using is labeled:
image

The left delete = Backspace, the right delete = Delete.

Previous versions of Xojo: both keys removed Navigator items. Now only one or the other removes Navigator items.

1 Like