Debugging Web and Desktop App Together

I have a Desktop Application that needs to communicate with a Web Service Application, but I don’t seem to be able to run both applications simultaneously through the IDE. When I run the Web Service, it launches properly, then I run the Desktop app, which hangs on the Launching Application screen. After a few seconds on the Launching Application screen, it goes away but the program does not launch. If I stop it and try running it again, it immediately ends. Under messages, I do not get a Launched or Ended message for the Desktop Application in any of these examples.

I have tried creating a fresh Web and Desktop App and am running into the same situation.

I have also tried resetting and altering the Firewall rules in Windows, setting different variations of Private, Domain, and/or All to Any/Any, but none of these seem to have any effect.

I am running Version 2019 Release 3.1.

Has anyone ran into a similar situation? And if so, were you able to resolve it? Any assistance on this would be appreciative.


You can do this if you run the desktop project first you can then run the web project but not the other way around.

Yes its a long standing issue, most annoying especially when testing for bugs.

Wayne, I just tried that here on two new empty projects, the web project fails to start.

It would be nice if this didnt happen, but even different versions use the same shared area/resources (whatever the clash is, same named ipc?) causing conflicts.

The safest bet would be to run one in a VM.

Are your projects named the same? I don’t recall having issues debugging a web project and a desktop project at the same time when creating my licensing system.

Update: I just tested and there is no issue with 2019r1.1 when the projects are named differently.

1 Like

Tim the legend, I keep forgetting that, even unsaved projects and projects without the .exe extension (web) share some metaphysical connection :wink:

MyApplication.exe :slight_smile:

Both are named differently at the project level, as well as the App Name under the Build Settings.

Did you try it web first then desktop as Wayne suggested? It seems to work here now with a different windows app name under Build Settings>This Computer

Yeah, that seems to work. It’s not ideal, but at least I can start debugging. The Desktop App is supposed to call the Web Service to populate the App on the Open event, but I can move that to a button for now.

Thanks everyone for the assistance!