Debug window area is too small

When debugging, the debug area in the workspace is too short.

If you enlarge it, you reduce the Code Editor display area.

New workspace does not display a Debug area.

Is it possible to get the Debug data in its own window ?

BTW:
From Xojo 2015r1 thru 2021r1.1

There was plenty of room in RealStudio for both code and variables. The Xojo IDE’s usage of screen real estate is suboptimal, to say the least.

3 Likes

I opened a new Workspace window in my external screen (and I noticed it does not have a copy of the Debug stuff), wrote this, then forgt about it.

The next run, the debugger data was in that second wndow… and I was asking myself why I lost the debug stuff until I watched the second monitor…

It is not really possible to Copy data from that area (excepted in recent version, for some error messages).

The more I think at that, the more I beieve an external Window with the debug stuff will be more effective.

Back when we had squared screens mabe was better to stack things at the bottom, but RS had it on one side.

Now that we have wider and wider monitors, Xojo decides to waste that wide space and pile up things in the botom :man_facepalming:t2:

Have you looked recently how small the Language Reference default window is ?
To get that, you have to run Xojo for the first time on a machine (or clears Xojo Preferences, or add a new User [I think]).

Also, adding a New Event (for example), on macOS, the sheet window is so small (vertically speaking)… so you have to scroll or type “Op” to select Open…

A little change here and there is welcome (yes, this is irony).

Even my duo screen was tall enough for a taller AddEvent sheet window.

my habit : toggle it on or off via icon & drag the size.
but if you want a own debug output window, just use a app window and output your data there.

Forum for Xojo Programming Language and IDE. Copyright © 2021 Xojo, Inc.