Debug[MyApplication].exe has stopped working

Something weird is going on with 2019R1 and Windows 64 bit web apps. I’ve been troubleshooting all morning trying to pin down why a new app I started working on yesterday was crashing every time I tried to run it in the debugger. It’s been a long process of removing method’s modules, classes, etc. Nothing worked. Finally I just rebooted and then started a brand new blank app. It ran fine in both 32 bit and 64 bit. I saved the blank project and then tried again and it crashed immediately. Switched to 32 bit and it would run. So then I closed Xojo and removed all plugins except the default 5 and tried again. It still crashes the blank project. I have repeated this numerous times. One thing I have noticed, after saving the blank project the file size is huge for being blank at 2723 KB.

Hive mind has anyone encountered anything like this?

Web projects have a default icon, so an “empty” binary web project could be rather large if you didn’t clear the icon.

I wouldn’t touch 64bit windows projects with a barge pole.

A basic windows web project seems to be about that size, nothing odd there.

Can you upload your test sample project that crashes?

Just as a counter point the IDE is a 64 bit windows app :slight_smile:

No idea why a web project would behave that way though

Tim I’ve been creating fairly large web projects for several years and they average much smaller in size.

Julian, 64 bit window stand alone web app s has bee n my standard for our internal apps for several years. Never had this kind of problem before.

Norman, My next step is to uninstall 2019R1, re-download and reinstall. Looking forward to beers with you next week and hopefully by then I have solved this issue.

Maybe it’s been a while since you’ve looked.

Test scenario:

  • 2019r1
  • macOS 10.14.4
  • No DefaultWebProject.xojo_binary_project
  • New Project > Web
  • Save As > Binary

Result: 2787360 bytes ~ 2.8mb
Edit: And, for science, after clearing the default web icon: 27680 bytes ~ 29kb

Well… uninstalling and reinstalling did not help. On the pus side deleting the 512 and 256 icons reduced the saved file size significantly at 163KB. I never use those sizes in mu apps normally so that explains why the saved size for a blank project surprised me.

Open new project using name MyApplication.
Change build settings to Windows and set to 64 Bit
Change Shared Build Settings to Stand Alone
Turn off Hi-DPI
Save project.
Crash Message: DebugMyApplication.exe has stopped working


Well it is definitely machine specific. I installed 2019R1 on a test Windows 10 system and the issue doesn’t repeat itself. Now what the hell did corporate IT remote install to my laptop that is making this happen.

Very odd. Anything in event viewer or shown in debugview?

It might also be worth a try running the x64 redist in C:\Program Files\Xojo\Xojo 2019r1\Extras\Windows Runtime\Installers but I can’t see why that would fix an intermittent issue. Anti-virus? Slowly unlocked file?

Well I appear to have resolved the issue by moving the project from my desktop to elsewhere on my local HD. It must be something to do with corporate anti-virus settings that have recently changed. I’ve been working in a different dev environment for the past couple of weeks so it had to have happened recently during that time frame. We were sold in December and our Corporate IT folks have been transitioning a lot of network and endpoint protection systems. Gah! Ack! That was incredibly frustrating!

Much as I’d like to beers wont happen as I wont be there

Well Boo! That really sucks for all of us who were looking forward to seeing you.

ditto but it is what it is

Did your IT department move your desktop to a network share perhaps?

No. I suspect they tweaked the endpoint protection settings to block something that the debugger is doing on the desktop that it doesn’t block in other user file areas. This wouldn’t be the first time that running the debugger triggers “suspicious activity”. Usually I would get a warning and could create an exclusion but this was just silently blocking and causing a crash.

Long time ago, I moved a testing app created on macOS to the Windows Desktop * and get troubles. Then, I stopped doing so and never had this trouble.

  • Faster to do; now I create a new directory in the user directory and test from there.