Debug App Crashes Without IDE Errors

I’m scratching my head trying to figure out what’s wrong with an app that crashes in the debugger without throwing any exception errors in the IDE. I’ve tried setting breakpoints but the app still crashes without any of the variables appearing to be amiss. I get the following in the Windows Event Viewer:

Log Name: Application
Source: Windows Error Reporting
Date: 7/14/2017 10:31:02 AM
Event ID: 1001
Task Category: None
Level: Information
Keywords: Classic
User: N/A
Computer: XXXXXXXX
Fault bucket 109030033825, type 1
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: DebugApplication.exe
P3: 58f7477d
P4: XojoGUIFramework32.DLL
P6: 58f74b28
P7: c0000005
P8: 001b3aa5

Log Name: Application
Source: Application Error
Date: 7/14/2017 10:30:33 AM
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Computer: XXXXXXXX
Faulting application name: DebugApplication.exe, version:, time stamp: 0x58f7477d
Faulting module name: XojoGUIFramework32.DLL, version:, time stamp: 0x58f74b28
Exception code: 0xc0000005
Fault offset: 0x001b3aa5
Faulting process id: 0x18fc
Faulting application start time: 0x01d2fc40c1a1f102
Faulting application path: Z:\Development\DebugApplication.exe
Faulting module path: Z:\Development\DebugApplication Libs\XojoGUIFramework32.DLL
Report Id: d5260503-8c17-49e4-b5a7-314ad27be1a8
Faulting package full name:
Faulting package-relative application ID:

There have been a few posts about getting stack traces on Windows

or search for "minidump or “mini dump”
Those are helpful to us

I won’t have time to get back to this again until next week so I’ll download the tool and do a mini dump then.

Are you using any Declares? If you are check your types:


I ran the app in WinDbg and got the following:

[code]Microsoft ® Windows Debugger Version 10.0.15063.400 X86
Copyright © Microsoft Corporation. All rights reserved.

CommandLine: “Z:\Development\DebugApplication.exe”
Symbol search path is: srv*
Executable search path is:
ModLoad: 00f70000 00fcf000 GUIStubWin32.exe
ModLoad: 77cf0000 77e73000 ntdll.dll
ModLoad: 77590000 77670000 WOW64_IMAGE_SECTION
ModLoad: 77590000 77670000 C:\WINDOWS\SysWOW64\KERNEL32.DLL
ModLoad: 75690000 75831000 C:\WINDOWS\SysWOW64\KERNELBASE.dll
ModLoad: 746a0000 7472a000 C:\Program Files\Bitdefender\Bitdefender Security\atcuf\262823883760000000\atcuf32.dll
ModLoad: 758d0000 75a2f000 C:\WINDOWS\SysWOW64\USER32.dll
ModLoad: 75670000 75685000 C:\WINDOWS\SysWOW64\win32u.dll
ModLoad: 753e0000 7540b000 C:\WINDOWS\SysWOW64\GDI32.dll
ModLoad: 74bc0000 74d1a000 C:\WINDOWS\SysWOW64\gdi32full.dll
(1ecc.aa4): Break instruction exception - code 80000003 (first chance)
eax=00000000 ebx=00000000 ecx=6a7c0000 edx=00000000 esi=01391760 edi=00d05000
eip=77d9748c esp=010cf7fc ebp=010cf828 iopl=0 nv up ei pl zr na pe nc
cs=0023 ss=002b ds=002b es=002b fs=0053 gs=002b efl=00000246
77d9748c cc int 3
0:000> g
ModLoad: 75300000 75325000 C:\WINDOWS\SysWOW64\IMM32.DLL
ModLoad: 6ade0000 6ca64000 Z:\Development\DebugApplication Libs\XojoGUIFramework32.DLL
ModLoad: 75380000 753c6000 C:\WINDOWS\SysWOW64\SHLWAPI.dll
ModLoad: 77b60000 77c1e000 C:\WINDOWS\SysWOW64\msvcrt.dll
ModLoad: 74ed0000 750e1000 C:\WINDOWS\SysWOW64\combase.dll
ModLoad: 75570000 75650000 C:\WINDOWS\SysWOW64\ucrtbase.dll
ModLoad: 74d80000 74e41000 C:\WINDOWS\SysWOW64\RPCRT4.dll
ModLoad: 74790000 747ae000 C:\WINDOWS\SysWOW64\SspiCli.dll
ModLoad: 74780000 7478a000 C:\WINDOWS\SysWOW64\CRYPTBASE.dll
ModLoad: 74d20000 74d7a000 C:\WINDOWS\SysWOW64\bcryptPrimitives.dll
ModLoad: 75330000 75371000 C:\WINDOWS\SysWOW64\sechost.dll
ModLoad: 77750000 777b3000 C:\WINDOWS\SysWOW64\WS2_32.dll
ModLoad: 77a70000 77b55000 C:\WINDOWS\SysWOW64\COMDLG32.dll
ModLoad: 750f0000 75178000 C:\WINDOWS\SysWOW64\shcore.dll
ModLoad: 76040000 77418000 C:\WINDOWS\SysWOW64\SHELL32.dll
ModLoad: 776c0000 776f6000 C:\WINDOWS\SysWOW64\cfgmgr32.dll
ModLoad: 75a30000 75f9e000 C:\WINDOWS\SysWOW64\
ModLoad: 77670000 776b5000 C:\WINDOWS\SysWOW64\powrprof.dll
ModLoad: 74e50000 74ec7000 C:\WINDOWS\SysWOW64\advapi32.dll
ModLoad: 77a60000 77a6d000 C:\WINDOWS\SysWOW64\kernel.appcore.dll
ModLoad: 77c80000 77c8f000 C:\WINDOWS\SysWOW64\profapi.dll
ModLoad: 778e0000 779cc000 C:\WINDOWS\SysWOW64\ole32.dll
ModLoad: 75fa0000 76034000 C:\WINDOWS\SysWOW64\OLEAUT32.dll
ModLoad: 777c0000 7783b000 C:\WINDOWS\SysWOW64\msvcp_win.dll
ModLoad: 734d0000 734d8000 C:\WINDOWS\SysWOW64\SensApi.dll
ModLoad: 71600000 71606000 C:\WINDOWS\SysWOW64\MSIMG32.dll
ModLoad: 712e0000 71475000 C:\WINDOWS\SysWOW64\urlmon.dll
ModLoad: 74480000 74488000 C:\WINDOWS\SysWOW64\VERSION.dll
ModLoad: 738f0000 73afa000 C:\WINDOWS\WinSxS\\COMCTL32.dll
ModLoad: 734a0000 734c4000 C:\WINDOWS\SysWOW64\WINMM.dll
ModLoad: 74490000 744bf000 C:\WINDOWS\SysWOW64\IPHLPAPI.DLL
ModLoad: 70ca0000 71178000 C:\WINDOWS\SysWOW64\d2d1.dll
ModLoad: 75180000 752fd000 C:\WINDOWS\SysWOW64\CRYPT32.dll
ModLoad: 75840000 7584e000 C:\WINDOWS\SysWOW64\MSASN1.dll
ModLoad: 70860000 70a56000 C:\WINDOWS\SysWOW64\DWrite.dll
ModLoad: 72350000 72580000 C:\WINDOWS\SysWOW64\d3d11.dll
ModLoad: 715d0000 715f3000 C:\WINDOWS\SysWOW64\prntvpt.dll
ModLoad: 71560000 715cd000 Z:\Development\DebugApplication Libs\MSVCP140.dll
ModLoad: 71540000 71555000 Z:\Development\DebugApplication Libs\VCRUNTIME140.dll
ModLoad: 73110000 7333b000 C:\WINDOWS\SysWOW64\iertutil.dll
ModLoad: 70bb0000 70bd3000 C:\WINDOWS\SysWOW64\WINMMBASE.dll
ModLoad: 721a0000 72223000 C:\WINDOWS\SysWOW64\dxgi.dll
ModLoad: 70c30000 70c9a000 C:\WINDOWS\SysWOW64\WINSPOOL.DRV
ModLoad: 73d90000 73dab000 C:\WINDOWS\SysWOW64\bcrypt.dll
ModLoad: 74030000 740a5000 C:\WINDOWS\SysWOW64\uxtheme.dll
ModLoad: 75410000 75545000 C:\WINDOWS\SysWOW64\MSCTF.dll
ModLoad: 74730000 7474f000 C:\WINDOWS\SysWOW64\dwmapi.dll
ModLoad: 779d0000 77a54000 C:\WINDOWS\SysWOW64\clbcatq.dll
ModLoad: 70a60000 70baf000 C:\WINDOWS\SysWOW64\propsys.dll
ModLoad: 714b0000 714d1000 Z:\Development\DebugApplication Libs\Appearance Pak.dll
ModLoad: 707c0000 70828000 Z:\Development\DebugApplication Libs\Crypto.dll
ModLoad: 71530000 7153d000 Z:\Development\DebugApplication Libs\GUIKit.dll
ModLoad: 70bf0000 70c2d000 Z:\Development\DebugApplication Libs\Browser Plugin.dll
ModLoad: 71520000 71529000 Z:\Development\DebugApplication Libs\Internet Encodings.dll
ModLoad: 70710000 707bb000 Z:\Development\DebugApplication Libs\REALSQLDatabase.dll
ModLoad: 706b0000 70702000 Z:\Development\DebugApplication Libs\RegEx.dll
ModLoad: 714a0000 714af000 Z:\Development\DebugApplication Libs\Shell.dll
ModLoad: 705b0000 706aa000 Z:\Development\DebugApplication Libs\SSLSocket.dll
ModLoad: 726a0000 7280e000 C:\WINDOWS\SysWOW64\windowscodecs.dll
ModLoad: 72580000 725c4000 C:\WINDOWS\SysWOW64\dataexchange.dll
ModLoad: 72230000 72343000 C:\WINDOWS\SysWOW64\dcomp.dll
ModLoad: 70090000 70181000 C:\WINDOWS\SysWOW64\twinapi.appcore.dll
ModLoad: 71490000 71496000 C:\WINDOWS\SysWOW64\RICHED32.DLL
ModLoad: 70520000 705a1000 C:\WINDOWS\SysWOW64\RICHED20.dll
ModLoad: 75650000 75667000 C:\WINDOWS\SysWOW64\USP10.dll
ModLoad: 704e0000 70511000 C:\WINDOWS\SysWOW64\msls31.dll
ModLoad: 72810000 72ab3000 C:\WINDOWS\SysWOW64\msftedit.DLL
ModLoad: 71bb0000 71ce6000 C:\Windows\SysWOW64\Windows.Globalization.dll
ModLoad: 71b50000 71ba2000 C:\Windows\SysWOW64\Bcp47Langs.dll
ModLoad: 71b20000 71b45000 C:\WINDOWS\SysWOW64\globinputhost.dll
ModLoad: 73450000 7349e000 C:\WINDOWS\SysWOW64\mswsock.dll
ModLoad: 6f7d0000 6f84d000 C:\WINDOWS\SysWOW64\DNSAPI.dll
ModLoad: 753d0000 753d7000 C:\WINDOWS\SysWOW64\SI.dll
ModLoad: 6f720000 6f728000 C:\Windows\SysWOW64\rasadhlp.dll
ModLoad: 6f510000 6f559000 C:\WINDOWS\SysWOW64\fwpuclnt.dll
ModLoad: 702a0000 704d6000 C:\WINDOWS\SysWOW64\D3D10Warp.dll
ModLoad: 70280000 70294000 C:\WINDOWS\SysWOW64\resourcepolicyclient.dll
ModLoad: 70270000 70291000 C:\WINDOWS\SysWOW64\prl_umdd10.dll
ModLoad: 70250000 70268000 C:\WINDOWS\SysWOW64\winhttpcom.dll
ModLoad: 734e0000 73580000 C:\WINDOWS\SysWOW64\WINHTTP.dll
ModLoad: 73c50000 73c60000 C:\WINDOWS\SysWOW64\ondemandconnroutehelper.dll
ModLoad: 6cb00000 6cb76000 C:\WINDOWS\SysWOW64\webio.dll
ModLoad: 733d0000 733d8000 C:\WINDOWS\SysWOW64\WINNSI.DLL
ModLoad: 741f0000 74254000 C:\WINDOWS\SysWOW64\schannel.dll
ModLoad: 744e0000 744f1000 C:\WINDOWS\SysWOW64\mskeyprotect.dll
ModLoad: 6d2e0000 6d300000 C:\WINDOWS\SysWOW64
ModLoad: 6d1c0000 6d1eb000 C:\WINDOWS\SysWOW64\TASN1.dll
ModLoad: 744c0000 744db000 C:\WINDOWS\SysWOW64
ModLoad: 741e0000 741e8000 C:\WINDOWS\SysWOW64\DPAPI.DLL
(1ecc.aa4): Access violation - code c0000005 (first chance)
First chance exceptions are reported before any exception handling.
This exception may be expected and handled.
*** ERROR: Symbol file could not be found. Defaulted to export symbols for Z:\Development\DebugApplication Libs\XojoGUIFramework32.DLL -
eax=006f006f ebx=05b6f980 ecx=002e0069 edx=010cf89c esi=05b73998 edi=05b73994
eip=6af93c89 esp=010cf87c ebp=010cf8d8 iopl=0 nv up ei pl nz na pe nc
cs=0023 ss=002b ds=002b es=002b fs=0053 gs=002b efl=00210206
6af93c89 8b01 mov eax,dword ptr [ecx] ds:002b:002e0069=???
0:000> g
(1ecc.aa4): Access violation - code c0000005 (!!! second chance !!!)
eax=006f006f ebx=05b6f980 ecx=002e0069 edx=010cf89c esi=05b73998 edi=05b73994
eip=6af93c89 esp=010cf87c ebp=010cf8d8 iopl=0 nv up ei pl nz na pe nc
cs=0023 ss=002b ds=002b es=002b fs=0053 gs=002b efl=00210206
6af93c89 8b01 mov eax,dword ptr [ecx] ds:002b:002e0069=???
0:000> g

I finally discovered that it was crashing when HTTPSocket.Disconnect was called at the end of the routine. I don’t know why that was causing it to crash without throwing an exception error but removing it solved the problem.