DBMS api library loading fails

Hello @Christian Schmitz

I am using MBS SQL Plugin to connect to database.

I have downloaded the requisite library file from the MBS website MSQL Libraries 8.0.18.

I was able to use the software on one of the machine for a few days with and run it in IDE.

I then compiled it for Windows 64. I started receiving an error

libmysql.dll file not found.
DBMS api library loading fails.

I then downloaded the previous version of the library, MYSQL Libraries 8.0.11, and copied the librmysql.dll from it.

Deleted the MYSQL Libraries 8.0.18 from my system.

And the App started working. I was successfully able to connect to the database and work on it.

I then installed the App on another Windows 64 system, with the libmysql.dll file copied from the previous machine.

Now I have started getting the error on the second machine for the MYSQL Library 8.0.11 libmysql.dll file as well.

I tried install Libraries of 8.0.18 as well. But things don’t seem to work.

The App is unable to connect to the database.

Can you please help me understand the issue.



Please use Dependency Walker to check for dependencies like a missing visual studio runtime dll and beruft you have 32/64 bit correct.

Hello @Christian Schmitz,

As per your suggestion, I did download Dependency Walker to identify the missing .dll

However, I don’t know how to identify the missing file with Dependency Walker.

Is there some way, I can send the Walker image file to you, to help me find out.

  • Gaurav

you could post a picture here?
in the left list of DLLs, close all, then open one level. Anything showing red?

Hello @Christian Schmitz,

I tried to take the snapshots, but I understand only URL images can get pasted in this forum.

I don’t have any document hosting facility currently, from where I can share to outside the organisation.

Is there some other way by which I can share with you the screenshots.

Anyways, I don’t see any red Dlls missing in the Walker.

Dependency Walker, great tool to see what DLLs are missing.

e.g. here shows DLL is 64-bit (on 32-bit Windows won’t work), requires Visual C Runtime 14 and LibSSL + LibCrypto DLLs.


If you have trouble there, please check each DLL for missing dependencies.