Database Tutorial Error

I am new to Xojo and was going through the book available on the Learn section of the site. I am working on building the app in Chapter 12.4 Creating and Connecting to a Local Database. I have started form scratch several times and am consistently getting the same error. When I build and run the app, I get no errors. Upon testing it and adding info, I get the error “no such table: addressbook”. The best I figure is it is not making the database table. I’m not sure what I’m missing. Here is a link to the project as I have it: Address Book


Your project works fine for me (Mac OS X)

Your project also worked fine for me on Windows 8.1.

I just built this same project on a machine running Windows 7 and am getting the exact same error message. Any insights?

Can you share the project?

Forgive me, I’m a real beginner at this. Please tell me what to do to share the project.


Dropbox or something similar works fine.

My project file is now in my public folder on the dropbox account for Is this all you need to access it?


Mea Culpa. My apologies for wasting peoples’ time. I had a missing space in one of the SQL command strings. It was hard to see the difference just looking at the listings, but when I started sending my strings to msgbox(es) it became clear.

Use an SQLite Editor. When you see problems like this that don’t jump out at you, open the DB in an SQLite Editor (my personal favorite is Navicat, but tons of them on the market )and paste the query in and run it. Does a lot better job of reporting where the SQL syntax error is.

And always, always, ALWAYS check the database for errors after every SQL statement (SQLSelect and SQLExecute). It would have spotted the error right away (well, told you have an SQL syntax error at least).

From the BKeeney Briefs archives:

That is one full year since I used SQLite with Xojo, but aren’t we able to send SQL commands to it right from the Xojo Editor ?

The built-in Database Editor is…um…not very good. Use an external editor.

Correct, copy and paste from the debugger.