Dark Mode - Xojo Code Theme

Uh… when you use Dark Mode, should the Syntax Colors for the IDE change automagically?

I switch to Darkmode, and still get black text on black background… or do you have to manually change the theme anytime you switch modes (if so, that would be a real pain when testing Darkmode in your app)

I switch the modes via an AppleScript App on my Desktop.
Sometimes I got also the dark mode themed source code editor after I was switched back to light mode.

I cannot get a “proper” theme unless Darkmode is in effect BEFORE Xojo is started…
you can’t seem to switch modes after Xojo is running and have the Code Editor syntax colors change

[quote=417671:@Dave S]I cannot get a “proper” theme unless Darkmode is in effect BEFORE Xojo is started…
you can’t seem to switch modes after Xojo is running and have the Code Editor syntax colors change[/quote]

If you had set specific colors for the code editor then it won’t switch automatically. It will continue to use those colors you chose. If you open the preferences pane and reset all the colors to their defaults then they will automatically switch as you move from dark to light mode and vice versa.

And i would like to add that i would expect it to be this way. Please do not change this.

Well , I never had changed the colors… but doing a Reset in Preferences seems to have fixed that issue

Not for me. To reproduce:
Open a Xojo project so that source code is shown in light mode.
Switch to dark mode (via my AppleScript app)
–> Code is now correct colorized for dark mode
Switch to light mode (via my AppleScript app)
–> Code is now still colorized for dark mode

My AppleScript app is just:

tell application "System Events" tell appearance preferences set dark mode to not dark mode end tell end tell