Dark mode has white text area


if I switch to dark mode, the text area has a white background, therefore I can’t see the cursor.
What do I have to change to see the cursor ?

Using OS X with M1 and Xojo 2020.2

Hi @Johann_Kienbrandt

I can’t reproduce it using Xojo 2020r1 (and later) on macOS 12.x :thinking:

on my MacBook Air it works fine, but not on my desktop.

on my iMac M1

Screenshot? Code? Example? Do you compile as Intel or as ARM?

If this was a problem someone would have found that way earlier.

I compile as ARM64-bit

Looks fine on my M1 Air.

Here using a Mac with M1 processor.

If we’re talking about the IDE (2020r1, in this screenshot), here is how it looks like:

If we’re talking about the compiled app (using 2020r1), this is how it looks like here:

Found it !!

I pressed the Reset button and. now it works !

thank you all

Hah!, I was going to ask you about the colors set in the “Coding” settings from the Xojo preferences!

Glad you found it! :slightly_smiling_face:

The preferences need values for light and dark mode. At least the background should have 2 values.

1 Like