Current Project won't run on M1 Mac Mini

Just installed the latest Xojo and Xcode on a new Apple Silicon Mac Mini. Attempting to run my current iOS project in the Simulator, I get a nasty error message that says the project was compiled for iOS Simulator, but linking for MacOSX. Rats. I’ve filed a bug report with the complete error message.

I don’t believe Xojo is supporting Apple Silicon yet in 2020r1.

We’re going to need to see your project.

Added the affected project file to the Feedback case


ALL ioS example projects on apple silicon return the error message:

"Linking Executable
ld: warning: ObjC object file (/var/folders/pb/27kz3_254lx6mv47dxxjt9fr0000gn/T/xojo scratch 10894/untitled [CBF4B275]/iOS_x86_64/#rbframework.o) was compiled for iOS Simulator, but linking for MacOSX
ld: entry point (start) undefined. Usually in crt1.o for architecture x86_64

I am having the same error, is there a fix for this? Using Xojo 2020 1.2 on a Mac mini m1

2020 Release 2 fixed it.

1 Like

Just upgraded my license to the latest version and it is now working properly. Thanks for the tip!