CurlMBS Linux wont run

II created a small test app using CurlNMBS and CurlNMultiMBS, and it runs fine on Windows 32/64 bit and Mac 32/64 bit. But on Linux Mint, it popup an error:

“An exception of class CURLNMissingFunctionExceptionMBS was not handled. The application must shut down. Exception Message: Missing function _curl_multi_init. Did you use LoadLibrary?”

Can anybody give me a clue what this is about?

CURL Library is installed on Linux?

Please call LoadLibrary method on Linux to load the curl library you like to use.
Normally it should load or /usr/lib/ automatically, if it is there.

I’ll change it to look in more places to avoid some loading errors.

If it doesn’t fix by install libcurl package, please try newer plugin here:

On the fresh Linux Mint install is cURL 7.58.0 already installed, but I still get the same error message with the new plugin.

Can you check where is?

[quote=437620:@Christian Schmitz]

locate libcurl returns this:

/usr/lib/x86_64-linux-gnu/ /usr/lib/x86_64-linux-gnu/ /usr/lib/x86_64-linux-gnu/ /usr/lib/x86_64-linux-gnu/ /usr/share/doc/libcurl3-gnutls /usr/share/doc/libcurl4 /usr/share/doc/libcurl3-gnutls/NEWS.Debian.gz /usr/share/doc/libcurl3-gnutls/changelog.Debian.gz /usr/share/doc/libcurl3-gnutls/copyright /usr/share/doc/libcurl4/NEWS.Debian.gz /usr/share/doc/libcurl4/changelog.Debian.gz /usr/share/doc/libcurl4/copyright /usr/share/lintian/overrides/libcurl3-gnutls /var/lib/dpkg/info/libcurl3-gnutls:amd64.list /var/lib/dpkg/info/libcurl3-gnutls:amd64.md5sums /var/lib/dpkg/info/libcurl3-gnutls:amd64.shlibs /var/lib/dpkg/info/libcurl3-gnutls:amd64.symbols /var/lib/dpkg/info/libcurl3-gnutls:amd64.triggers /var/lib/dpkg/info/libcurl4:amd64.list /var/lib/dpkg/info/libcurl4:amd64.md5sums /var/lib/dpkg/info/libcurl4:amd64.shlibs /var/lib/dpkg/info/libcurl4:amd64.symbols /var/lib/dpkg/info/libcurl4:amd64.triggers [/quote]


there it is. There is where we try to load it.
If you call LoadLibrary manually and check the LoadErrorString error after this, what does it say?

Maybe there is a dependency missing?

LoadLibrary return true, and LoadErrorString is empty.

than it works!?

With curlmbs.LoadLibrary, I get the same exception after that, it wont work.

With curlnmbs.LoadLibrary, I get another exception after that:
Exception message: curl_url function missing

The lib seems to functioning after LoadLibrary (but how can I know what the lib path will be to manually load the lib?)

Just doing this in Linux cause the curl_url function missing exception:

dim u as new CurlNUrlMBS
u.Url = “

this sounds like the older CURL library you have doesn’t have the newer URL functions.

What does CURLNMBS.LibVersion say after the LoadAPI call succeeded?

It returns: libcurl/7.58.0 OpenSSL/1.1.0g zlib/1.2.11 libidn2/2.0.4 libpsl/0.19.1 (+libidn/2.0.4) nghttp2/1.30.0 librtmp/2.3

curl 7.65 is current. I think 7.62 added URL functions.

Maybe you can manually install a newer version.
Or use CURLSMBS with the built in libraries.

I use CURLSMBS, CURLSMultiMBS and also CURLSUrlMBS and it seems to work. :slight_smile: