In the CubeSQL manual it says that I should be able to perform the following CubeSQL commands and return a RecordSet:


When I am logged in as admin via SQLite Manager or CubeSQL Admin, the results are displayed, but when I connect in as admin in my Xojo app (using SQLDatabaseMBS) the same commands return nil with the ErrorMessage:

Command doesn't make sense in current context.

I have tried connecting with and without a named database and get the same response. I am logging in as admin, so I have the privilege to see all database names.

Any clues on what this error might mean?

Have you tried debugging the code for the admin tool, it is on Github I think.

These two applications use the CubeSQL Plugin provided by SQLabs.

You seem to be facing an issue related to the MBS SQL Plugin. So your best chance is to contact MBS Support.

I thought it might be MBS related, but wanted to dismiss any logical issues first, since I would have thought SQLDatabaseMBS would just pass-through the SQL command and back with the RecordSet without evaluating it in any way.

BTW, it returns the RecordSet with CubeSQLServer, so I have used this as a workaround.

Well, the error message comes from CubeSQL.
Maybe you are not in the right mode to do this.

What do you mean by mode? How do you change modes with CubeSQL — there is no SQLDatabaseMBS.mode=XXX command?

The CubeSQL manual shows the call as a normal SQL command call.

I thought about wether you use a database or not.
Not sure if CubeSQL makes a differentiation there

Good suggestion, but I’ve tried the command both when I’ve connected to the server with a defined database and when none is define, with the same response.