Critical: Filetype sets are buggy!

I’ve been wrestling with filetype sets for the last week or so, trying to copy and paste them from one project to another sometimes works, but then dragging them in the navigator causes Xojo to crash. Exporting a filetype set produces an empty file. Trying the workaround of creating a folder in the project, dragging the filetype set into the folder, and then exporting the folder sometimes works, but often dragging the filetype into the folder causes a crash. I’ve lost track how many times Xojo has crashed on me in the last hour.

All of this has been verified by Xojo, Feedback #41662 and 41590, using Xojo 2015r3.1.

I’m just posting this to warn others that there is currently no reliable way to move a filetype set from one project to another. Hopefully Xojo will fix this ASAP, but until then save often and don’t expect to retrieve them from previous saves.

41590 isn’t “new” - I’ve found this occurs at least as far back as 2012r2.1 (maybe further I stopped looking at that version)
I looked into that when this was reported
Could have sworn there was a pre-existing report but I cannot find such a thing

41622 (not 662) I haven’t looked at yet - its sunday :slight_smile:

But if you’re getting crashes & the Apple Crashes reporter shows up those logs would be useful

All that said are you manually versioning this project using binary projects ?

Ah, sorry, I misspoke. Xoxo doesn’t crash, it “quits unexpectedly”. Same functional result for me, a big difference to you…:(

I’ve updated the Feedback report to indicate that.

And yes, I’m manually versioning using binary projects.

There is a way. Not terribly straightforward, but it works :

  • Insert a folder into the project
  • put the FileType inside
  • Right click the folder and export it

Afterward, you can drag the FileTypes1.xojo_binary_code into a new project.

Of course, it would be much easier to copy and paste.

Unfortunately, trying to drag the FileType into the folder causes Xojo to quit unexpectedly if the FileType set has more than about 5 types in it. That’s bug report #41649.

I’ve reconstructed the FileType set that was causing this problem and made it into three smaller sets. Hopefully they will behave better the next time I need to retrieve them.

John, I tried to reproduce what you describe in a new project. I stuffed a FileType with a dozen or so types. Tried to drag it in and out of folders, up and down. Duplicated it. Copied them and pasted them in another project. Never any crash or quit.

You may be experiencing project corruption.

Try creating a new project, select everything in your new project, and paste in the new one after deleting all but App into it. You will have to paste separately methods and properties for App.

[quote=231421:@John McKernon]
And yes, I’m manually versioning using binary projects.[/quote]
With a project the size of your thats masochistic
even a local svn would go a long way to making you life easier and I could actually tell you how to insert something by hand
In a binary - not a chance

The specific issue you’re running into trying to drag the file type set around looks to be the IDE being Out of memory
Even without the 500+ images in the project it uses 1.9 Gb