Creating snap for Web 2.0 App fails because of excutable stack flag

I like using for software distribution of my applications under Linux.

The advantages for me are mainly the automatic update on the customer systems and the insensitivity to missing dependencies.

I have now created the first snap for a Web 2.0 application and have encountered a problem that hinders the automatic release by the SnapStore or requires a manual review.

The libraries

are marked with the executable stack flag which is not allowed there. I removed the flag of these 2 librarys with the command ‘execstack --clear-execstack’ and was able to build and upload/install my snap package without problems.

Question: Why is this flag set ? Is there anything against removing this flag ?

If nothing speaks against it Xojo could deliver this with the next release already without executable stack flag set. (then other Xojo users will have no problem when distributing via

If desired, I can gladly create a tutorial for distribution / deployment via snap.

Try to set Build Shared setting “Include function names” off

I tried it, as expected, it did not change anything.

The flag is set on the libraries. (something like a file attribute)

For me I solved the problem, I set it in my build process. I just wanted to share the solution and ask if there is a reason why the libraries are flagged.