Creating a "CopyFiles" build step in Ubuntu isn't working

I’m having trouble creating a “Copy Files” build step. I’m using Xojo 2018r4 and Ubuntu 18.04.2 LTS 64bit. I need to add several files and one folder to the copy files build step.

However, when I click the Xojo “Add Files” button, I get a “Add Files to Step” dialog which lets me select the files I want and returns them to the build step as it should when I click the dialog’s “Open” button.

But when I try to select the folder I want, clicking the “Open” button opens the folder rather than returning it to the build step. There doesn’t seem to be any way to select a folder.

So then I tried to use drag-and-drop from the Ubuntu file manager (Nautilus?) to the Xojo build step pane. That doesn’t seem to work either. The drag-and-drop mouse pointer never indicates that the Xojo build step pane is a valid drop target and so the operation fails.

I’m coming from a Windows 7 environment where I have been able to create copy file build steps that contain both files and folders but now that I’ve moved to Ubuntu as my primary work computer, I’m not having any luck.

Has anyone else seen this? Are there work-arounds?


You’ll need to create the proper folder hierarchy on Windows or macOS and create the copyfiles step there.

Wow. Ok. I moved my code to a Windows machine and created a “Copy Files” step and then moved it back to My Linux machine but what a pain in the arse. That’s an awful lot of aggravation just to get the “Copy Files” build step to work.

I’ve stopped using the “Copy Files” build step and instead use a “Script” build step. I was able to get the same net effect by issuing several “DoShellCommand” statements with calls to cp. I’m thinking that scripting is much more flexible than using the “Copy Files” build step even though it is more involved.

Many of us old timers have IDE Scripts just like this that date back to the time before Build Automation, so we definitely understand. However, once the team get this sorted for Linux, the BA steps are still the best option for controlling things for most users.

@Wes Westhaver,

We’re you unable to drag and drop the folders into the CopyFilesStep list?

[quote=427049:@Greg O’Lone]@Wes Westhaver,

We’re you unable to drag and drop the folders into the CopyFilesStep list?[/quote]

I was not able to drag-and-drop either the files or folders I wanted into the CopyFilesStep list.

I’m new to Ubuntu so I tried drag-and-drop from one Nautilus window to another Nautilus window just to see how it worked and it worked fine. But I was never able to get Xojo to receive any drag-and-drop items.

This is sorted in 19r1.