Crash with URLConnection

I am encountering an intermittent crash with the URLConnection object type, which is causing my Web Application to crash.

Unexpected error 9 on netlink descriptor 5

It is similar to the behavior described here:
I have checked that all of the URL’s I am using are valid, so their solution won’t work for me.

The source of the error seems to come from an implementation in glibc, outlined here:

I have sub-classed URLConnection to include references to the parent session and page, and I am creating a new WebSessionContext before interacting with the content received. Is it possible that some error is occurring in the URLConnection before it comes back into scope?

The app is running as a 64-bit Standalone Linux application, hosted on a Ubuntu 20.04 box. I have checked that all of the libraries specified in the requirements are installed and are up to date. I am running XOJO 2019 r3.1

Do you know if you can reproduce this with a stand-alone web app running on a diff. Linux machine?

This is already a third machine. Previously, it was running in a Docker image, using Ubuntu 16.04, and then on another Ubuntu 18 machine. We tried updated to the latest Ubuntu version to get the new glibc library, but it didn’t fix the issue.

Did you check

ldd /path/to/excutable
Please post the output

Or maybe you only have an ipv6 ?
It could be xojo requires an ipv4

Output from ldd: (0x00007ffdc664c000) => /opt/sites/builder-dev/sltm/sltm Libs/ (0x00007f9c08fa1000) => /lib/x86_64-linux-gnu/ (0x00007f9c08da6000) => /usr/lib/x86_64-linux-gnu/ (0x00007f9c08d46000) => /usr/lib/x86_64-linux-gnu/ (0x00007f9c08c1d000) => /lib/x86_64-linux-gnu/ (0x00007f9c08bfa000) => /lib/x86_64-linux-gnu/ (0x00007f9c08bf4000) => /lib/x86_64-linux-gnu/ (0x00007f9c08be7000) => /lib/x86_64-linux-gnu/ (0x00007f9c08a98000) => /usr/lib/x86_64-linux-gnu/ (0x00007f9c08a7b000) => /usr/lib/x86_64-linux-gnu/ (0x00007f9c08a59000) => /opt/sites/builder-dev/sltm/sltm Libs/ (0x00007f9c086a8000) => /lib/x86_64-linux-gnu/ (0x00007f9c0868d000) /lib64/ (0x00007f9c0b4e3000) => /usr/lib/x86_64-linux-gnu/ (0x00007f9c0867f000) => /lib/x86_64-linux-gnu/ (0x00007f9c0860c000) => /lib/x86_64-linux-gnu/ (0x00007f9c085e5000)

As I said before, I’ve checked the required libraries, but I could have missed something.

The box we’re running currently is capable of both IPv4 and IPv6. The Docker environment was IPv4 only.

It seems to be ok, did you verified the require libary versions, so you are sure those are higher or match teh xojo required lib versions?

I did check the library versions, and specifically the glibc version, which seems to be a contributor to the problem. Each library is either at or above the listed level in the Xojo documentation. Unless they have failed to update their docs, it seems like an outdated library isn’t the problem.

Have you tried launching your app from the command line and then doing whatever it is that causes the crash to see what the output is?
NM. I see that in your first post.

See Http Socket Crashes WebServer :slight_smile: Seems this is still an issue.

Thanks :slight_smile: That’s actually the post I linked in my original post. As I said, I’ve checked that all of my URLs are correctly formatted, not malformed.

you could try to install libsoup2.4-1 maybe it’s not showing but on linux it would use that library as far as i know.

I have never heard this. Do you have details or a source?

It could be that URLConnection works with ipv6 (on all platforms) i’m not sure on linux. i do know some sockets sometime have trouble communicating over ipv6 or won’t work (TCPSocket, SSLSocket, ServerSocket etc). Not sure about URLConnection, probably depends on the system.

I just checked again, to be safe, but libsoup is installed. Additionally, it has been in environments with ipv4, ipv6 and both.

It currently has both address types