Crash Log Help Anomaly

I used Greg’s code in this thread? What’s missing?

When you build your project and set CopyFiles to Resources Folder, should you see an actual Resources Folder in the Show Package Contents of the built app? Or does everything just appear in the root directory?

Everything is in the root directory.

The correct dSYM file I guess

The dSYM file you use must be the exact same file that was created when you built the version that’s crashing as they are slightly different every time.

Can you add code to the app UnhandledException event and display a message when an exception occurs? That might be more useful for us

Ok, still in need of some help.
What should I be putting in the UnhandledException event of the App to pass on the right info to track this?

Currently I have in the App.UnhandledException event

MessageBox( "Exception “+exc.Reason +”, Error " + exc.ErrorNumber.ToText )
Return True

Which yields “General.txt” Not found, Error 0

I am accessing the file in the same manner as my previous App which worked ok only difference was it was 2020 R1.2 and this is 2020 R2.1

According to the documentation it should be SpecialFolder.Resources instead of SpecialFolder.Resource.
On the other hand, looking for Resource in the Xojo Documentation gives an example that uses SpecialFolder.Resource.
Very confusing.
You can try using Resources. Maybe it helps solving your problem.

Thanks for chiming in Paul but it wasn’t that. Looking on the positive side of things I have learnt a lot about debugging, symbolicating and remembering to document things that I have already solved in previous projects :slight_smile:
… and the winner is… remember to have your copyfiles resources signed! When I was tracking a different bug I deleted the copyfiles and re added them but didn’t put them back in the right step order. While it doesn’t seem to matter on your own devices it means they are not accessible in a distributed version. Sorry for taking up so much bandwidth and appreciate your patience.
As a suggestion maybe the sign build step can be locked in as the last step :slight_smile:

1 Like

Do you check the signature? I always do that because the signing can fail in interesting ways. For MAS apps using Transporter I get an error when the app isn’t signed correctly.

Transporter didn’t give any errors for any of my uploads. How do you check the signature before committing to the store.

That’s really odd. See https://www.macissues.com/2015/11/06/how-to-verify-app-signatures-in-os-x/ .

codesign --verify

and

spctl --assess --verbose

Those are valid for macOS. Not sure if this also works for iOS apps.

1 Like
Forum for Xojo Programming Language and IDE. Copyright © 2021 Xojo, Inc.