Could not create a temporary .itmsp package for the app “appname.ipa”

I get this message when I run transporter - even though I can transfer tis ap to my iPhone and run it after compiling it for the app store.

“No suitable application records were found. Verify your bundle identifier ‘com.JHLConsultants.SplitUP’ is correct”

Any help regarding ways to fix this would be greatly appreciated.

Did you create a new app instance on

I suspect transporter can’t communicate with the app store because the app instance isn’t created yet.

Thank you Jeremie,
The instance has been created, but such a long time ago that I think there is conflict between the current version and the new. I tried recreating all the provisioning profiles and now I can’t compile int for that App Store. The joys of dealing with Apple.

Now getting this message: Domain=IDEProvisioningErrorDomain Code=9 ““” requires a provisioning profile.” UserInfo={IDEDistributionIssueSeverity=3, NSLocalizedDescription=“” requires a provisioning profile., NSLocalizedRecoverySuggestion=Add a profile to the “provisioningProfiles” dictionary in your Export Options property list.}

Hi Philip,

I had the same issue with Transporter. Did you find a way to solve that problem?




Did you create an entry for your app in

You need to go to the apps store as Jeremie suggests, then create an entry there so that when you upload with transporter, it knows where to pout it. The process is simplified for Mac apps when using AppWrapper, ut still need to use Transporter for iPhone apps.

Good news, I found a way to solve that issue. Regarding to my research, many developers have also that issue. Hopefully, that will help someone. So here is how I solved it:

  1. I followed these 3 steps:

Creating A Provisioning Profile that comes with the extension .mobileprovision.

Creating A Certificate file (with a password) that comes with the extension .p12.

Creating An App ID to represent my app on the App Store.

  1. I have uploaded my app with Transporter, but received that message:

"Could not create a temporary .itmsp package for the app “appname.ipa” "

  1. I have opened Terminal, and typed in xcode-select --install .
  2. I have created an entry in App Store
  3. I have emptied the cache of my computer (from there, it started to work well…)
  4. I have downloaded Xcode app (you will need it for verification from Apple)
  5. I shot down my computer
  6. And I have tried Transporter again :-).