CopyFile Step do not copy folder

I’m testing an app on Linux Ubuntu 18.04 with Xojo 2019r1.1.
CopyFile step, after build, copies 2 files and 1 folder. Destination is Resources

When running remote debug from my dev machine (macOS) to remote Linux VM it works fine, all items (files and folder) are copied.
When running debug from Linux IDE, the single files are copied but the folder is not copied.

When building the app for Linux, from macOS IDE, single files and folder are copied to Resources.
When building the app from Linux IDE, the single files are copied but the folder is not copied.

There were previous feedback cases because adding a folder to the copyfile step was not possible, but they are solved.

Is there a workaround ?


  • build automation scripts are not a solution in this case
  • I tried with copyfile destination Resources and App Parent Folder, copy folder failing with both

Thanks !

Are the Write permissions OK there ?
(modify your code to copy these items to a permission free location to know if this script kind works on your running Linux flavor)

It seems write permissions are ok as the single files are copied correctly.
Permissions on original files and folder are the same.
Besides, Also, it works when running remote debug which shouldn’t have better permission than Xojo IDE running from Linux IDE.

To be sure I granted all permissions for all files and folder to everyone (owner, group, public) and still no folder copied.

Problem with the Linux IDE, maybe ?

seems so …

(] Feedback #57306 issue reproduced …