Controls don't update when compiled

I have a 2017r3 binary project on Ubuntu 16.04 which I saved to text (xojo_project) to use with Git. But when I duplicated a button and changed the caption of another, the changes aren’t being updated when compiled. Have tried restarting Xojo but no help – can see changes I made but they won’t compile - seems the old version is what is compiled.
Does anyone have an answer for this?

Make sure you press TAB or ENTER when you change the caption to commit the change.

Thanks Greg. The change is committed because when I reopen the project it’s there OK. But when I run the project the old caption is there and the duplicated button containing updated code is missing.

Is it possible that you’re setting the caption in the Open event?

Nope, there is only an Action event with no caption changes.

This is a desktop app BTW

I have found a workaround - yay - copied and pasted all controls into a new project.
Now it’s business as usual!


Thanks for being here for us Greg, Bye.

Happened again but this time I saw what happened. It’s the Xojo IDE on Linux which is still laggy especially in a VM.
So one thinks one is duplicating the control which unbeknown to you has somehow become deselected and Xojo duplicates the window instead, moving the original copy down in the tree out of sight, appending the duplicate windows name with a “1” (which is how I eventually noticed it). So when trying again to duplicate the control it works but of course there’s no entry point to the duplicate window so changes in the code seem to have no effect when compiled. Makes me feel like an ijot.
Hope the IDE on Linux can be realtime soon!
So the answer is copy your work to the original window and delete the duplicate.