ContainerControl on a PagePanel without Transparency results in a black ContainerControl

  1. Create a new Desktop Project
  2. Place a PagePanel on the Window
  3. Place a ContainerControl in the PagePanel
  4. Set Transparent to False for the ContainerControl and the ContainerControl in the PagePanel

Is this an expected behavior or an issue? I’ve created a Feedback Case with a simple example Project.
feedback://showreport?report_id=51895

We are forced to use Transparent = True for ContainerControls, which may lead to a degraded performance on Windows Systems.

BTW: If you take a Screenshot (Shift+CMD+4, move the Mouse over the Window, Press Space Key and the Mouse Key) on a Mac, the PNG shows a Transparent square where the black square is to see in the App. :wink:

Edit: Added Feedback Link

Hi Sascha, the black box is shown on macOS only or also Windows? (Can’t test windows for now until tomorrow)

I did a test, and in #4 even if you set Transparent ON for the ContainerControl you get the black box on macOS. Only setting transparency for the ContainerControl in the PagePanel. A past version of Xojo show a white box instead of black, and I’m sure I didn’t change the BackColor for the ContainerControl.

Another workaround is to set the HasBackColor to True and use the color that you need.

Just FYI, this looks fine in windows.

Thank you Julian.

I don’t have much experience with Xojo. I don’t understand why the Background section for ContainerControl1 list:

  • Custom Color
  • Background Color
  • Backdrop
    but when the container is inside the PagePanel the Background section for ContainerControl11 list:
  • HasBackColor
  • BackColor
  • Backdrop

I don’t see any changes to the ContainerControl1 if I change something there (that’s why I said in #4 you can have the selection as OFF or ON without changes), so when that options matter?

Edit: sorry this is off-topic I think it is better to post it in other thread

I confirm on Mac 2017R2.1 under High Sierra ; it must be an old undiscovered bug.

You will have to use if TargetWindows in it’s Open event to set it opaque.

Michel, it shows black or white with 2017R2.1?

For me it shows black with the latest version I have but white with 2017R2.1.

Edit: thank you for the idea. I added an open event handler with:

#If TargetMacOS Then Me.Transparent = True #EndIf

Windows only: Be careful, because I have a big project with many page panels and much more containers in which controls are visible when they shouldn’t. But only if all transparent settings are set to False. I can’t reproduce this in a simple project.

[quote=382609:@Alberto De Poo]Michel, it shows black or white with 2017R2.1?

For me it shows black with the latest version I have but white with 2017R2.1[/quote]

Strange. I just ran the project attached to the feedback case, and I see exactly the same as the picture above. Black rectangle.

Same here. That‘s the rason why i‘ve not marked it as BetaBug.

It happens in 2016R3 with a 32 bit run as well.