Console Remote Debug - Pi

Am new to console application.
I try to Set up the Remote Debugger on the Pi.
I copy the “Xojo\Xojo 2020r1.2\Extras\Remote Debugger Console\linux ARM” and placed in Pi (/home/pi/)
and extract the Linux ARM folder and run the remote debugger console

  • Machine Name: Test_Pi_1
  • Download Directory: /home/pi/
  • IP Address: 22.40.0.159 ( my windows PC IP)
  • Maximum Connections: 10
  • Auto Launch: yes
  • Public: yes
  • Password: xxxxxx

Note:
console application developed in windows
I set below settings in my windows
Pi IP: 22.40.0.178

But when i run remotely i get below error
"Malicious Termination occurred. "incorrect password

below imga is pi terminal screenshot
image

This should be the address of the pi

This was an issue for me in the past, I had to use the folder that contained the executable for the remote debugger itself for it to work.

For example the one that worked was:

DownloadDirectory=/home/user/Desktop/console/Linux 32-bit/RemoteDebuggerConsole (Note: you need to edit to reflect your own username and file paths, this will not work directly, but it needs to point to the same relative place)

"Stub->IDE SOS, Could not create file or folder"

The last line of the error is showing a permission related problem with your download directory, not only the password.

You will need to edit your RDS.config textfile in the remote debugger folder to place the binaries it creates inside the folder of the RemoteDebuggerConsole.

This was the only way I got it to actually work, any other folder resulted in: “Stub->IDE SOS, Could not create file or folder” in the terminal output.

Try updating the download directory to be the exact same as the Remote debugger binary, it worked for me.

Thanks for response.
I already changed the Ip address and Path
but still i got same error.
attached image
22.40.0.178 - Pi IP address
22.40.0.157 - My windows IP


image

When you installed the remote debugger application, did you unzip it on a windows environment and copy the decompressed folder over to the Pi, or did you copy the raw archive file and decompress on the pi itself?

copy the raw archive file and decompress on the pi itself

When you entered the details into the IDE, did the IDE detect the remote debugger automatically or did you need to enter all the details in from scratch?

copy the raw archive file and decompress on the pi itself

Correct.

Also, did you ever get the GUI debugger to work (I understand you need console)? That was my first try as it was simple to check that connection and path was all ok.

So this has been a recurring issue for me and the only way I found to resolve it was the following:

  1. delete previous copies on the pi
  2. copy the archive and decompress on the pi desktop (Console and GUI)
  3. add firewall rules in windows machine
  4. run Xojo IDE
  5. run and configure GUI remote debugger first (it will be auto detected and show up italics in choice listbox)
  6. Run a GUI hello world, validating that credentials, network and file permissions work
  7. Decompress console version, use file path pointing to console debugger, same credentials
  8. Console should also show up automatically in IDE.

I have to repeat this procedure frequently for some unknown reason, but it was what worked.

did you ever get the GUI debugger to work (I understand you need console)?
No , Because my Pi dont have UI. below attached screen

Yep, that looks correct.

Are you certain the credentials match?
Did this pi console auto-detect by the IDE or dit you have to enter all the info yourself?

I enter the details my self (manually)
image

It should have automatically shown up in italics and only needed to be assigned a password. This is could be indicative of a fire wall issue, check that valid rules exist under windows firewall and that they are indeed working.

Obviously, the simplest and quickest way to verify is to delete the IDE stub, very temporally disable windows firewall and try to see if it auto detects the debugger. If it does, then you will know the problem is with your windows firewall, if not you can eliminate that as a possibility. Just be sure to be careful and resume your firewall.

This was also an issue when I first setup the debugger, I almost gave up until I discovered a problem with the windows firewall rules, they were entered, but not actually working.

Anyhow, that’s all I have left, sorry.

1 Like

@Pathma_Mu

These are not standard internal IP addresses. Are these public IP addresses of your computers on the internet?

Pi Ip Address
image

My windows IP
image

That would be the problem. The remote debugger stubs will not route packets over the open internet. I suggest that you use a VPN or a service like ZeroTier, both of which I know to work.

1 Like

Noted with thanks, will continue to explore the XOJO Pi capabilities