Compiler failed assertion at InterRep.h:119

All of a sudden today I get a Compiler failed assertion at InterRep.h:119 whenever I try to compile my app, and Xojo aborts with a fatal error. It now occurs with all recent backup of my app which all compiled fine until this morning. I was using Xojo 14r2.1 when this started and so I downloaded Xojo 2015r1 and it does exactly the same thing. I deleted the ~/Library/Cache/Xojo folder and removed all non-Xojo plugins.

The Feedback app captured this info:

Location: InterRep.h(119)
Condition: mType == kStoredSInt32
Platform: Macintosh Intel 10.102

So now I’m completely blocked on compiling any version of my app!!! Any ideas what else to try?

Please report a feedback case.

Can you build on another computer?

Hi Christian

I’d filed it as Feedback http://feedback.local/showreport?report_id=38243

I haven’t tried it on another computer, but I did realize that there are several External project components that would have been common to all the recent backups I’d tried. And I’d added a global enum to one of those external modules during the interval when this problem started. So I’m now going to check that out…

Cheers, Joe