Compile to Intel on M1 system not working

Is it a known issue that when you compile on a M1 device (running macOS Big Sur 11.6 using Xojo 2021R2.1) to Intel, the .app file does not launch on an Intel device?
It just starts and quits without a crash report.

Or isn’t it meant to work in the first place and do we need to compile on Intel for Intel devices?

Edit: Rosetta2 is not installed on my M1 device (and I have no plans to do so).

In the meantime I tried with installing Rosetta2, and still the compiled Intel versions do not launch on an Intel device.

Looks like I have to keep an Intel MBP to compile for Intel. :frowning:

You’ll need to re-codesign the app because the IDE now does an ad-hoc codesign for big sur.

codesign --force --sign - /path/to/yourapp.app

1 Like

Sorry, forgotten to add that the app was code signed correctly with Appwrapper.
So that’s not the reason why it doesn’t work.

I tried a new empty project and the same happens.

Does the app crash before the first line of code? Do you see anything in the Console? What version of macOS do you have on the Intel side?

It’s happens with an empty project and then just compiling it for Intel.
There is no crash report either. You just click on the app icon and nothing happens.

On the MBP M1, macOS Big Sur is install, on the MBP Intel the same version.
When I compile an ARM version on the Intel device, the ARM app works fine on the M1 device.

And again, it is code signed with Appwrapper with my own certs.

do me a favor and open Terminal and type the following and post the result:

codesign -vvvv /path/to/your/bundle.app

There’s two things I would suggest.

@Greg_O_Lone believes it to be the code signature, please make a version available to download and I’ll run it through my internal diagnostics, this will check a whole bunch of things and provide very detailed code signature report.

The second thing is to fine up console, enter the name of your application into the search field and then click “Run” or “Start” or whatever they call it now. This will start it tracking for an errors related to your application. It should reveal there what the problem is.

–prepared:/Users/cdv/Desktop/My Application.app/Contents/Frameworks/XojoFramework.framework/Versions/Current/.

–validated:/Users/cdv/Desktop/My Application.app/Contents/Frameworks/XojoFramework.framework/Versions/Current/.

/Users/cdv/Desktop/My Application.app: valid on disk

/Users/cdv/Desktop/My Application.app: satisfies its Designated Requirement

Can you share your empty app? If anyone had problems like that it would have been brought up here long ago. I did an empty Intel app here in on my Air. And it started fine on High Sierra.

Looks like something related to the Intel payload. You should make a MessageBox(“OK”) app, compile it, compress tar.gz ou DMG its exec tree, unpack it into the Intel Mac, verify if does not run, open a FB case and attach it for analysis if so.

Forum for Xojo Programming Language and IDE. Copyright © 2021 Xojo, Inc.