Compile on Windows

Hello Forum,

Before I post my questions, I tried to search the forum to find answers but was not successful. I’m trying to compile my Xojo app on Windows Xojo IDE 2019r3.1. I have two questions.

  1. In “Build” option, it seems that only “x86 32-bit” is working. When I select “x86 64-bit”, the compilation takes forever so I just kill the process. Is this normal?

  2. Compared to my Macbook, it takes much longer to compile the same program on my Windows IDE: Windows Xojo 2 minutes vs. Macbook Xojo 1-2 seconds. Is this normal? Or is there any setting I can change?

If this issue was already discussed before on this forum, can you please post a link for me?


64 bit compilation takes longer.
Check the optimization level.
With aggressive level it can take hours.

Generally, I find Xojo on Windows can perform better than on macOS. I typically always have Build for 64-bit as the default for Windows.

Note: I am using 2019r3.1 and Mac hardware with Bootcamp, so same hardware for both OS’.

A couple things that I do, that I feel helps, is:

A.) - I don’t place my Xojo project in a “Cloud” folder, i.e., DropBox, OneDrive, iCloud, etc. (I use a source-control system instead of shared drives).

B.) - On Windows, I exclude the Xojo app directory and my root project folder from anti-virus scanning.

On Windows 10, to exclude folders from scanning, I go to:
Settings > Update & Security > Windows Security > Virus & Threat Protection > (new window) > Manage Settings > Exclusions > Add or Remove Exclusions > Add an Exclusion

I find the above two things contribute to reducing any disk contention, with regards to the Xojo IDE, and potentially make things run better.

Note: I’m not recommending you compromise your anti-virus in any way - this is just what I do :wink:

Edited: to add that I do the above for all my IDE’s, regardless of who makes it.