Compilation failed Xojo 3.0

After update to 3.0 I can’t run myProject in the simulator.

I get this message:
Compilation of “myProject.” failed.
An error occurred when attempting to launch the application. You may need to delete the application from the simulator if it already exists.

What can I do?

Was your previous version 2021R2.1 ?

Check the needed XCode version (Xojo 3.9 release notes, I think)

Previous version was 2.1. I run xCode 13.1, the latest version.
Everything up to date, I think…

Are you still able to run in 2021r2.1?

Did you delete the app from the simulator?
Or erase contents and settings of the simulator device?

Did you try on another simulator device?

In 2021r2.1 no problems.
I restarted the simulator, I erased contents and settings of the simulator and I tried other projects and devices.

So the major change is that we updated the iOS SDK from 14 to 15 so there may be a new requirement for privacy methods. Check the iOS Capabilities panel and see if anything you’re using now has a check and/or options that you need to choose from.

Otherwise we’ll need to see your whole project.

Are you on an ARM (M1) Mac?

Thanks Gavin, it’s Rosetta!!! Solved.

1 Like

feedback://showreport?report_id=64582

Same problem on xojo 3.
Just spent far too long reading the feedback to find out that the easy fix is to
uncheck finder>preferences>Show all filename extensions
or
change the xojo app so it runs under rosetta.

Now works.

Forum for Xojo Programming Language and IDE. Copyright © 2021 Xojo, Inc.