Color Picker Window Problem

I working on an app and in the settings window I was trying out a color select option but decided not to use it. Now Since I didn’t save it with the color code I just quit with out saving, because no need to, wasn’t going to use it anyway. So later I go back to work on other things in the app, and when I run it the color window keeps popping up with the main window, which is impossible because there is no code to call it and even if there was it would of been only in the settings window and would only have been called with the push button and I did check the color code wasn’t saved. I can’t stop it from doing this. Even in the compiled app it keeps popping up.

There isn’t any code anywhere calling the color select window in this project.

Xojo 2020r2
Mac OS 11

Ok after a reboot its working correctly now, no more color select window. Very odd…

Well I’m now having this problem with MacOS 10.15.7. If I open Xojo (2019r3.2, 2020r2, 2021r1.1), start a new desktop project, and click run…the color picker comes up along with the window.

Similarly, I had previously been working on an app with a color picker in it, and it isn’t just debugging, but built apps now open the color picker on launch.

A reboot didn’t fix it for me. Anybody have any ideas?

I just realized if I change the application identifier, the issue seems to away. Fortunately this was in a “myapp” test, but if it happens in my main app I’d like to fix it for real. Is there somewhere I can look to clear this? I deleted ~/Library/Caches/com.[me].myapp but that didn’t fix it.

Its been a while so I don’t recall if I ever figured out what the cause was.

Of course the obvious thing is make sure its not XOJO’s IDE color picker window being left open.

This a guess on my part but perhaps you used the same identifier on both so perhaps XOJO was tying some settings or whatever from your app with the color picker to the new one. If changing the ID in “myapp” fixed it then I would think it would for your main app. Just be sure to use a unique ID’s for your apps.

Outside of this, I’m not really sure. It was an odd occurrence for me.

Found it. In “~/Library/Saved Application State” I deleted the “com.[me].myapp.savedState” folder and it seems to have fixed it.

Forum for Xojo Programming Language and IDE. Copyright © 2021 Xojo, Inc.