Color constants are not working for me

I have been struggling to figure out why changing the Window backcolor to a Color Constant is not working.

If i create an App constant of type Color then choose any of the colors from the selctor for Apple then use it in code, it is usually all black or not even close in color.

If i create the same constant under the window i get another different color that doesnt match the app.constant

Ive tried all the hex color constants directly from the Xojo Help files and even they dont match the colors shown.
Window1.BackColor =&cFF0000 should show a Red background but i get cyan
Window1.BackColor =Color.Red this shows cyan as well

i understand that i can use RGB but isnt the Hex value supose to match

When I use me.backcolor = in the open event of the window I get a red window, not cyan.

If i put this in the open event

	dim c as color  =  &cFF0000 
	me.BackColor= c  < when i break here

The variables window shows c as the cyan color = &c00F0F000

Even when i start a new project of type Console and have only this
dim c as color = &cFF0000

c changes to cyan

Well that’s weird I get c = &cFF000000. I’m running on Windows 10 with Xojo 2017R1.1.

Im using aMac.

after you told me it worked for you i thought it might be something else with my computer.
I am using version 2016 because when i used 2017 it crashed alot so i went back to using 2016 as it was stable.

I downloaded and tried this with 2017 and it works as expected.

Your code works (more or less, read below) when running on 2015r1.

[code] dim c as color = &cFF0000

Me.HasBackColor = True
Me.BackColor = c[/code]

BUT: where is the constant there ?

BTW: as per example from the LR, I add the line Me.HasBackColor = True; you do not show that line, but that window property may have been set in the Window Editor at design time.

The “Constant” i was referring to was described not shown since i cant show it other than a picture.

Me.HasBackColor = True… I enabled this in the designer.

As mentioned above this was a problem with my specific version on my specific computer and i have moved on.

Good !