Collect Items doesn't update Image paths

I just ran a “Collect Items” on a project with LOADS of xojo_image items. Upon completion, the actual png files attached to the xojo_image files were copied into the Images folder where I store those, but the xojo_image files were not updated with the new paths.

I’m running the latest 2021r2.1 prerelease (no build number) under Big Sur on an M1 mini.

Please move this to the General channel. This is not a regression or prerelease issue.

1 Like

??? - I don’t see this in 2020r1 …

That may be, but it’s not a regression between 2021r2 and 2.1.

In light of this, I am also now seeing that even after I “Resolve” the missing assets (which dirties the project) and save, the paths are still not being updated in the .xojo_image files after the new save.

I just tried 3 different searches and nothing comes up in Feedback.

Does anyone know if there is a NEW existing report?

BTW - this is the same as feedback://showreport?report_id=54806, but that was fixed back in 19r1.

New case and notes created.

feedback://showreport?report_id=65519

Using the IDE script command “DirtyAllProjectItems” after the Resolve dialog is satisfied fixes this for the next save.

It’s not great for version control since now ALL of the items are new marked as modified, but it resolves the immediate issue.

True but when I did it I put a note in the log to indicate why so many items had changed. Just make that step be a new build (doing nothing else).