Codesign for mac app store error

Hi there.
I have a big problem submitting an app to Mac App Store.
Xojo 2021 r2, and AppWrapper 4.3.1, when i sign an application for the mac app store and I try it I have the message “The application is damaged and can’t be opened. Delete the application and download from the App Store again” (see image)


In AppWrapper I checked my certificates and seems all ok

Blockquote
macOS version 11.5 (build 20g71)
Xcode and required tools check
0 /Applications/Xcode.app 12.5.1 (12E507)
0 /usr/bin/codesign 30.100.2
0 /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/codesign_allocate 980.1
0 /usr/bin/productbuild 763.0
0 /usr/sbin/spctl 313.140.4
0 /Applications/Xcode.app/Contents/Developer/usr/bin/stapler 33.0
0 /Applications/Xcode.app/Contents/Developer/usr/bin/altool 404.30
0 /Applications/Xcode.app/Contents/Developer/usr/bin/iTMSTransporter
0 /Users/Shared/awhelper 341.1.0.3.4
Xcode licensed: YES

— System-i snc di E. Piccini e S. Tamborini (65WV5BPG3S)
4 AIK 2022-05-29 login-db “3rd Party Mac Developer Installer” Good
AAK 2022-05-29 login-db “3rd Party Mac Developer Application” Good
ADK 2022-05-29 login-db “Mac Developer: Sergio Tamborini (CS7XAK62H7)” Good
AAK 2022-05-29 login-db “iPhone Distribution” Good
AAK 2022-05-29 login-db “iPhone Distribution” Good
ADK 2022-05-29 login-db “iPhone Developer: Sergio Tamborini (CS7XAK62H7)” Good
3 AAK 2022-05-29 login-db “Apple Distribution” Good
5 ADK 2022-05-29 login-db “Apple Development: Sergio Tamborini (CS7XAK62H7)” Good
1 WAK 2026-05-30 login-db “Developer ID Application” Good
2 WIK 2026-05-30 login-db “Developer ID Installer” Good

— Intermediate authority certificates
✓ 2030-02-20 login-db “Apple Worldwide Developer Relations Certification Authority” 7CAF690A25B739FE7B9B447AC178C5EE Good
✓ 2027-02-02 login-db “Developer ID Certification Authority” 1763908746353189132 Good

Blockquote

When I codesign the app for “website” (outside the appstore) all works fine.

Any suggestion?

Thanks a lot for now!

Yesterday a guy had problems with the same error. The culprit were some html files that were copied into the app.

1 Like

Move it to the Applications folder and try again.

If that still fails, please use the “Contact Ohanaware” option on the “Help” menu to send me an e-mail with your log file and some other data.

1 Like

In this project there is no html files… in other I have some, but in this specific one no… Anyway I’ll give a look in the projects where there is. Thanks for the suggestion.

All done but the problem still alive :frowning:

Sended by email right now… Thanks for the support

For the others… I solved (with @Sam_Rowlands help) removing all certificates, then generate them again and reinstalled.

I think people like Sam (and @Christian_Schmitz too for other cases) are very special, because they go beyond their role and help people (like me) to understand and learn every day!

3 Likes

These are photographies of your screen?

Instead of, just try to press Cmd-Shift-4 to take a screenshot as file. :slight_smile:

Forum for Xojo Programming Language and IDE. Copyright © 2021 Xojo, Inc.