Cocoa NSInternalInconsistencyException was not handled

Apple just rejected my app based on an error that I’ve not seen in my testing.

The app seems to run fine in my own clean development environment so I’ve not been able to recreate the error.

The app uses the following non-Xojo classes that
MBS AppStore classes (which work fine in other apps)
macFileOperationMBS (not tried before) - file move and copy commands - all related to opendialogs and security scoped bookmarks.
MacOSLib security scoped bookmarks (not tried before)

Its nice that it tells me how to catch the exception - which implied that it is one of the MBS classes causing it - but where should I start to look?

This is going to be a tough one crack unless you can reproduce it. IMHO the exception is occurring within the Apple frameworks.

I’ve seen these in the past and normally restarting the machine makes it go away.

This is most probably related to Open/Save dialogs in sandboxed apps. It seems to have started with OS X 10.10, when Apple made sandboxed apps follow more rigorous rules.

My plugin catches the unhandled NSException there.
You may want to check the stack trace (written on console).

Looks like you might have been right Sam. I didn’t change any code but did add exception error catches at the end of all methods and submitted it again. This time apparently no crash in the testers machine and it was accepted.