I got a report that a webapp which I gave access to for testing, doesn’t work on ChromeOS client.
For this test I deployed as cgi , shown in an iframe on a website.
So I got ChromeOS and indeed it was not working. The webapp loaded extremely slow and on mousemovements it disappears from screen for a few seconds. Response on keystrokes doesn’t work.
Again, I tested on Safari, Firefox, IE and even Chrome-browser and it worked perfectly fine.
Is there any experience with ChromeOS ?

I’ve only see people discussing ChromeBooks - usually as “buy one & install linux”

Searching our forums for mentions of ChromeOS turns up only this other thread

That was my idea too. Didn’t expect anybody using it ChromeOS at all.

ChromeOS is the new “netbook” - cheap but just not that functional at this point - although that seems to be changing
Maybe one day
Installing a full linux distro makes them a workable cheap laptop if you’re not too demanding

Ok, what I learned is that I am not going to support this platform.
BTW I also had performance issues with Ubuntu 12.04 LTS running my webapp in Firefox, CentOs with Firefox worked fine.

I am surprised by these comments.
This should work fine.

[quote=122568:@olivier vidal]I am surprised by these comments.
This should work fine.[/quote]

No idea for Chrome. For Ubuntu, could it be due to the heavily graphic nature of this environment UI ?

I’m surprised Chrome on ChromeOS isn’t the same as Chrome on some other OS but ….

Chrome on ChromeOS is more tied to the OS than the others.

It’s clear that software vendors and developers like us must manage expectations to avoid putting too much effort in fixing the just 1% problems

And all Linux distros being 1.68% of the total OSes

Seems Chrome OS represents only 0.2% of web traffic

So we are talking about much, much less than 1% !

yes, but I do not see why an operating system fully optimized for the web (Chrome OS), and using the most powerful web browser (Chrome), function poorly with a xojo web app.

On this chromebook, websites appear quickly? what is the score indicated by

The advantage of a web app is that it should run on any operating system, desktop or mobile system, from the time it uses a modern web browser.

I agree. It could be due to a number of things, but chances are only Xojo Inc. Can do anything about that. Web apps depend on their framework, and if for some reason ChromeOS browser does not like Xojo Web code, workarounds apart from using pure HTML seem extremely remote.

Joost remark is fully justified. We developers have enough work making sure apps work fine with common browsers such as Internet Explorer and Safari, to divert all resources for a still anecdotal browser. When ChromeOS grows to a more significant share of the market, it will be possible to address it.

[quote=122806:@olivier vidal]
The advantage of a web app is that it should run on any operating system, desktop or mobile system, from the time it uses a modern web browser.[/quote]
Thats the ideal
But with all the custom CSS tags and features of HTML that each vendor does / doesn’t support and which ones they support correctly there’s still a LOT of “this works in this browser but not here” going on.
Not just in Xojo apps but in web sites & other web apps as well.

Internet Explorer being an excellent example of peculiarities, but with 20-30% of traffic, one can invest into it.

I just tried ChromeOS on Parallels on my Mac going to:

It’s loading just fine in the Chrome browser there.

Ok, the problem was reported to me by a friend using Asus C200MA-KX002 chomrebook.
I did the same as Greg did when I got this report: got ChromeOS on Parallels on my MBP.
And yes, I got exactly the same my friend reported, just a very poor experience.
This morning I repeated the test with the demo Greg was using above, and again I saw that also this application was working very flawed, or even not at all.
Except the inconsistent slow responding, the Google maps is flickering, most of the time the map-layer itself invisible, I could not click on any item in the right listbox, the application sometimes is completely freezes for 10 seconds. In short: not workable for the end-user.
I am happy to see that ChromeOS as a Parallels VM is quite comparable with the physical installation, which makes it usable for serious testing.
Thanks Greg for taking the trouble to install ChromeOS too, but I am still not convinced it’s working fine. Since the application of Eddie’s Electronics is working fine on every OS+browser I have, even Chrome, except on ChromeOS.
I am curious why it seems to work with Greg. For the time being, I just exclude ChromeOS since it’s only 0.2%.