Checking installed linux libraries

Hi there
how do you linux people check the installed libraries when launching a xojo app ?
did someone make a small method to do that,
and that is willing to share ?

I installed yesterday a fresh linux mint 20 on a virtual machine, then copy xojo in it
xojo launchs fine, seems to work, but will my compiled apps work too ?
I saw this in the system requirements :

how can I check that all these libraries are installed or not ?


Mostly only libunwind8 has to be installed cause a Linux install without GC is rare

The ldd terminal command is use to display app library dependencies.

does this mean that all the needed libraries are loaded and ok ?

jy@jeanyves-vm:~/xojo2020r1$ ldd Xojo (0x00007ffc649e4000) => /home/jy/xojo2020r1/./Xojo Libs/ (0x00007f1d5560f000) => /lib/x86_64-linux-gnu/ (0x00007f1d55408000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d54c57000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d54b52000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d54b40000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d54af1000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d54ac5000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d54ab9000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d54996000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d5496e000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d5478d000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d5472d000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d54602000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d544c5000) => /lib/x86_64-linux-gnu/ (0x00007f1d54376000) => /lib/x86_64-linux-gnu/ (0x00007f1d5436b000) => /lib/x86_64-linux-gnu/ (0x00007f1d54365000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d54360000) => /lib/x86_64-linux-gnu/ (0x00007f1d5433b000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d5431e000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d542fc000) => /home/jy/xojo2020r1/./Xojo Libs/ (0x00007f1d53f4b000) => /lib/x86_64-linux-gnu/ (0x00007f1d53f30000)
	/lib64/ (0x00007f1d57da0000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d53f28000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d53f16000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d53f0e000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d53ed7000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d53da4000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d53d87000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d53d6e000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d53c67000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d53c20000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d53b61000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d53b5c000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d53b4f000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d53b40000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d53b3b000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d53b36000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d53af4000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d53ae9000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d53ae4000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d53ad3000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d53abc000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d53ab1000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d53a0a000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d539d2000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d539cd000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d539a1000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d53992000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d53788000) => /lib/x86_64-linux-gnu/ (0x00007f1d5376c000) => /lib/x86_64-linux-gnu/ (0x00007f1d5370c000) => /lib/x86_64-linux-gnu/ (0x00007f1d536e1000) => /lib/x86_64-linux-gnu/ (0x00007f1d536c3000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d536b7000) => /lib/x86_64-linux-gnu/ (0x00007f1d53644000) => /lib/x86_64-linux-gnu/ (0x00007f1d5361b000) => /lib/x86_64-linux-gnu/ (0x00007f1d535ca000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d53591000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d53564000) => /lib/x86_64-linux-gnu/ (0x00007f1d53536000) => /lib/x86_64-linux-gnu/ (0x00007f1d5352d000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d53523000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d5351b000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d53513000) => /lib/x86_64-linux-gnu/ (0x00007f1d534bc000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d5342c000) => /lib/x86_64-linux-gnu/ (0x00007f1d5337f000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d53363000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d53342000) => /usr/lib/x86_64-linux-gnu/ (0x00007f1d53224000) => /lib/x86_64-linux-gnu/ (0x00007f1d53201000)

I believe ldd will display “not found” for entries that are a problem, but that may vary by distro.

So I’m inexperienced at Linux but installed it to see how Xojo ran on it. I have a fresh install of Mint, and ldd doesn’t show anything is not found, but the help file only looks online. I figure it’s a missing libwebkitgtk-3.0-0 but I can’t for the life of me figure out how to install it. The line in the docs “sudo apt-get install libgtk-3-0:i386 libwebkitgtk-3.0-0:i386” results in it saying it couldn’t locate the package. And “sudo apt-get install libwebkitgtk-3.0-0” says there’s no installation candidate. Help a Win/Mac guy out?

This might be relevant:

Yeah, those were what made me install it to horse around in the first place. And between those posts and the feedback case, I understand it’s probably a missing libwebkitgtk, right? But I can’t figure out how to install it. I was hoping someone here had a suggestion.

To be clear, I’ve got both mint 19 and Mint 20 here and the language reference is working just fine when installed with the Debian package.

In Mint when I went to Xojo and clicked Download, it gave me the tgz so I unzipped it and tried running it, and the local docs didn’t come up. Just the online docs come up in Firefox. After your post I thought “aha, I guess Mint uses Debian packages so I’ll just install that and I’ll be good with the dependencies!” So I did, and the online docs still don’t work. No internet = no docs. :frowning:

On the plus side, the compiler feels speedy.

I just tried on Ubuntu (20.04, 64 bit) as well. Downloaded the deb, installed it (had to use the command line, it wasn’t supported in the software installer), and find that it also only uses Firefox for the help. So, like with Mint, if I have no internet I can’t get to the docs. I’m a Linux novice but have a lot of experience with Windows and Mac and wow is this unintuitive. Every time I try using Linux I’m reminded of why it hasn’t taken over the world yet. LOL

libwebkitgtk-3 has been deprecated for a while now. We prefer libwebkit2gtk for our HTMLViewer since 2018r2, but will fallback to libwebkitgtk-3 on older distros that may not have libwebkit2gtk installed.

Okay, thanks. I just tried installing that and still neither Mint nor Ubuntu will show local docs. I guess I’m still missing something, and am glad I don’t develop on Linux.

You’re not missing anything, this is a bug on our end. It looks like we haven’t updated our logic and are still looking up libwebkitgtk-3 to see if we can load the local documentation.


Okay, in feedback case 61796 both Robin and Greg said they aren’t seeing the problem so I thought it was me. Thanks for confirming I’m not bonkers. :slight_smile:

@Geoff_Perlman see there is no internal help because of this logical error. Small hint even with installed webkit2 it is not coming up. Please don’t blame me and don’t blackmail me. Quod read demonstrandum

Older distros ? Ubuntu focal must be older. Much older. Cause it has the same error.

then why does the local docs work on all of your test machines (greg, robin, see the feedback)
and all of us end users can’t make it works on our test linux ?

Because we have no libwebkit3

would be nice to have some way of installing it ? people at xojo seems to succeed at it ?