Chapter 9: StyledTextEditor no longer works correctly...


Xojo has a programming textbook ( and there seems to be an issue with chapter 9’s “StyledTextEditor” example (pages 151-155). (I tested it with edition 3.0 and the example worked fine without any issues.)

However, with edition 4.0, there’s a strange problem. Here’s how to trigger it:

  1. Add some text to the RTF-styled textarea.
  2. Hightlight a word and change its font.
  3. Now, hightlight all of the text, and the font will MAGICALLY change for all highlighted text, whether you gave it that font, or not.

Any workarounds, or an errata available?

Thank you. :slight_smile:


Are you on Mac or Windows? What version of the OS? What version of Xojo?

I ask because I’m using 2019r3.1 on macOS 10.15.5 (Catalina) and I can’t reproduce the error.

When I highlight all of the text, the font does not change.

Have you tried the completed example project for that chapter?

Yes, I am on a Mac (Catalina version 10.15.5) and am using the latest edition of Xojo (2019, release 3.1). At first, I opened the completed example provided by Xojo for the ebook, just to make sure it wasn’t me (or a coding typo) and I am getting the same (problem) result.

Would you like me to provide a video screencast that demonstrates the issue? This way, you can see it in action. :slight_smile:

Thank you much!


That would probably help, yes.