certificate confusion

I tried building my first iOS app, but the compiler objected: A development profile is required when building an iOS application. But I have one.
Okay, so I headed over to Xcode to take a look at my settings there:

Hmm, status is “revoked”, no idea why. Next stop is the Apple Developer Member Center:

I don’t see where it is saying that it is revoked or how to remedy that. Does any of you guys know what to do here?

I had the same thing happen… just deleted them and reloaded them from Apple again

Delete them, you mean physically in ~/Library/MobileDevice/Provisioning Profiles? Else I can’t see how to delete them. I tried that and downloaded them again, but that doesn’t seem to help.

uh… look at the [DELETE] button on the screen shot above that you posted

Well, yeah, I can delete and recreate them in the developer member center and download them. That doesn’t change Xcode’s opinion about my certificates being “revoked” though. Btw, nice to see you chime in here after our little disagreement on the select count(*) topic.

Disagreement… thats all it was… no worries :slight_smile:

What options are available with the cog button in Xcode?
Also, note that it’s your signing certificate that’s revoked and you’re looking at provisioning profiles in the developer center screenshot.

Export and Revoke…, both disabled. That’s Xcode 6.4 btw. I remember using Xcode 7, but at the time there was a problem with App wrapper, so I went back. I think Sam fixed this in the mean time, so I guess trying the newer Xcode version is on the cards.

Yeah, I did note that. In my Xojo app the code signing identity is properly entered in the build settings (Team). Maybe Xojo is really wanting to tell me that the code signing didn’t work, because the signing certificate has been revoked?

I can confirm there are no issues with AppWrapper 3 and Xcode 7.
What does the apple website say when you go to signing certificates?

Are you able to download and install the certificate through the website?
Delete the local revoked version first.

Gotta love the mess Apple made :stuck_out_tongue:

I already tried that to no avail…Gonna try my luck tomorrow with Xcode 7, thanks Tim!

Apparently I am not the only one to encounter this problem, Apple’s forum is steaming because of it. I was able to resolve the issue by closely following the steps given by apple on the forum:

Thanks for bringing this to the attention of the community and apologies for the issues you’ve been having. This issue stems from having a copy of the expired WWDR Intermediate certificate in both your System and Login keychains. To resolve the issue, you should first download and install the new WWDR intermediate certificate (by double-clicking on the file). Next, in the Keychain Access application, select the System keychain. Make sure to select “Show Expired Certificates” in the View menu and then delete the expired version of the Apple Worldwide Developer Relations Certificate Authority Intermediate certificate (expired on February 14, 2016). Your certificates should now appear as valid in Keychain Access and be available to Xcode for submissions to the App Store.