Catalina, zsh, and Shell.Backend

Hi All,

The hits just keep on coming for me today.

[quote][code]You’ve typed on the keyboard. You must allow
permission for the user to access the keyboard interface

Allow Deny[/code]
Catalina is giving me grief with Shells for systems where accounts are new and /bin/bash is no longer the user’s default shell. I “believe” that I can force a workaround by specifying my Shell instances’ Backend to “/bin/bash”, but that’s a lot of edits …

I’ve tried creating a Shell subclass and setting my Timeout, Canonical, and Backend defaults, but it seems that the Timeout and Backend values are not being recognized by my subclassed controls.

Any Pointers to dealing with a Shell subclass like this?

isnt timeout ignored on macOS ?
canonical just deals with send control chars to the shell itself so shouldnt have any effect
backend should apply though

have you tried just setting backend to “bash” ?

I’ll try that since it doesn’t seem to retain (or use) /bin/bash (on macOS).

As for the other 2, I do send control characters and setting timeout is a safeguard for when I was always forgetting on Windows. Old wounds heal slowly.

once bitten twice shy and all that