Catalina & XOJO2019

I updated to OS Catalina. Using my old XOJO-2015 resulted in desktop Mac apps that ‘were outdated’ because they should be int64 compatible. So I ordered a new XOJO2019.
That caused some problems with the graphics because graphics changed in 2018. With the help of this community the problem appears to be solved.

The new (small test) desktop apps that I created work under Catalina. But with an old larger XOJO source I run into the following:
When loaded in the XOJO environment the ‘run’ button is greyed out (???). I can ‘Build’ however. But the resulting binary again tells me (when started) it is incompatible with Catalina!!!
What is happening here?

In your project:
Have a look at: “Build Settings -> macOS”, and set it to 64bit.

That’s because your project is configured to be 32Bit.

Make sure you have 64-bit selected. Select macOS from the Build Settings in the Navigator, then check the Architecture on the right.

Edit: beaten by Mr Otter.

thanks, that did it.

That’s just because you have explained it in more detail :wink:

I love the prude forum hiding your first name … :wink: