Catalina Not Writing To App Support

Hi, I have a user on 10.15.1 on which our application is creating and writing to a folder in Application Support but it cannot be seen in Finder.

I am getting and checking a sub folder using

[code]Public Function GetApplicationDataFolder() as FolderItem
if not SpecialFolder.ApplicationData.Child(cProgramName).Exists then

if not SpecialFolder.ApplicationData.Child(cProgramName).Exists then
  //did not have Permissions to create so return err
  return nil
end if

end if

return SpecialFolder.ApplicationData.Child(cProgramName)
End Function

I then reference and use a sub folder for debug data

[code]Public Function GetApplicationDebugFolder(create as boolean) as FolderItem
dim f as FolderItem

f = GetApplicationDataFolder()

if f = nil or not f.Exists then Return nil

f = f.Child(cDebugFolderName)

if f.Exists then return f

if create then
end if

if not f.Exists then return nil

return f
End Function

I use this to write out a file into the debug folder

if myTempFolder=nil then
//show error
return nil

myTempFolder = myTempFolder.Child(“photoshop_script.jsx”)

if myTempFolder.Exists then
if myTempFolder<>nil then
If bs<>nil Then
App.ShowErrorMessage(kTextFailedToOpenTempFile, “title”)
return nil
App.ShowErrorMessage(kTextFailedToGetTempFile, “title”)
return nil

This all works without errors, and even printing out the native path shows the correct path.
It just is not in finder!

If i remove the debug folder it does not even create that. Which should cause all sorts of problems.

Application is code signed and notarized.
It has permissions in automation required
I even tested with full disk access.

I did notice that about 4 hours ago it did write out the file, but wont any more.

Any idea what is going on here

App Support is normally not visible.

Try opening Finder
Then click the Go menu
Press ALT and an option for Library will appear
Go in there and you may find the folder

Hi Jeff, I’m looking in the app support \ my subfolder already in finder.

The debug folder and / or the file within are missing.

Also app compiled with Xojo 2019r1.1

Have you tried turning it off & on again?

installed 10.15.2 and it went away

It might be worth noting that I encountered a handful of users who’re unable to write to the Temporary folder from my application. T’was infuriating as heck, I finally solved it by using the Caches folder instead.

Catalina is the best version of the macOS that they’ve ever made .

I kid you not about restarting windows macOS, it temporarily fixes some really weird issues.