Can't run Xojo programs in the IDE

Hi, I am having a real problem getting started.
I downloaded Xojo today and tried to do the Desktop QuickStart tutorial.
When I try to run it a small window with a progress bar that says something like processing code.
Then it disappears and the IDE window is all that’s on the screen. I assumed that I made an error and tried several times no joy.
Also after trying a few times the message reads Done Assembling Code. Next I tried several sample programs still no joy.
I followed the instructions to build the Picture Chooser. Same results again. Also built an app that was nothing but a window and tried to run it.
Same result.
I am running Xojo on a Del Inspiron 570 with 12 GB of RAM 64 bit OS still runs 32 bit just fine.
Running Windows 10 Home.

Any ideas?

Have you tried a quick reboot? I know its a corny line with Windows, but I had a similar problem the other day and the reboot fixed it.

Also, look in (probably C:\Program Files (x86)\Xojo\Xojo 2016r1.1) /Extras/Windows Runtime/Installers/ and run VC_redist.x64.exe just in case there was a problem with the install.

Give it a quick reboot after then let us know how it goes?

[quote=268940:@Vern Holford]I am running Xojo on a Del Inspiron 570 with 12 GB of RAM 64 bit OS still runs 32 bit just fine.

What OS version and is it up to date?

As Julian mentioned Xojo needs the new Microsoft C runtime installed (it is shipped with Xojo). If it’s not Xojo won’t run.

If .you run Windows update regularly you should already have it. If so then the problem is something else. If not you need to install it.

  • Karen

Possible that your virus scanner is flagging the debug app. I run Norton and unless I have the Xojo_binary project file saved in a folder marked as safe in Norton, it chokes on it. So I have a special folder I save all testing apps to. My main application I keep list in Norton as well since it stays in the same place.

This ‘virus checker being a plonker’ issue is becoming common and it is very annoying , many of my customers lack the knowledge, confidence, or trust to go to a virus checker and override whatever setting is preventing the installed app running.

I can say for certain that it has cost me hundreds in refund requests and I have no idea how many demo evaluations die at the starting line…

The OP said it was in the IDE, not the built app. I have no problems with customers running built apps since I started codesigning them.

Lucky you.
I do and I do too. :slight_smile:

Avast will block the run executable as described by the OP.

Hi and thanks.
You guys are really quick.
It turns out to be two things I had already tried separately.
I need to run Xojo as administrator and to shutdown of Avast
I will have to figure out how to get Avast to let the program run.
Thanks to you all --problem solved!