can't run my project

Hi All.

Something funny happening with my Xojo project.

I created a project on Windows, and then brought it home to work on my Mac. I’m NOT trying to build it, just run it.
When I open the project, the Run is disabled, and I can’t run it. I’ve looked through Preferences but nothing is standing out.

Any ideas?

Regards

That will set “Build Settings -> macOS” to “x86 32-bit”.
Why? Because on Windows you can’t build for macOS 64-bit.

Just an assumption: You’re running macOS Catalina. Which can’t run 32-bit applications. And since your project is configured to be a macOS 32-bit app -> you can’t run it, the IDE has the Run button disabled.
So have a look at: “Build Settings -> macOS”, and set it to 64bit.

You will then be able to run it on macOS Catalina. But you won’t be able to “build” it on Windows :wink:

1 Like

Terrible ui design. It should remain active and provide you with some information about why it isn’t working when clicked.

There should be a tooltip if you hover over it.

Tooltips should be that, tips, like run your project, and shouldn’t be used as a substitute for ui.

Where do I find build settings -> mac os to change to 64 bit. I’ve looked on the left hand side bar, and see macos, linux, Windows, but can’t find a way to change it.

Never mind… time to get back into the horseradish… I found it.

Regards

Select Build Settings -> macOS in the left side bar, and have the Inspector displayed in the right-side bar. Then select your build settings in the Inspector.