Can't install an apk file to an Android file


I have created an apk file which I want to install on several Android devices (I know the users and they’ll agree to install it).

My three attempts failed:
I tried putting the apk file on my server. I can then download the file using the Chrome browser of the device, which just downloads the apk (no install prompt), but for an unknown reason, the zip extension is added to the resulting file (“”).
As I’ve read, apk is a kind of zip format, so I tried removing the “.zip” extension. Then, the Android’s file browser still sees the apk like a browsable folder/zip archive (I can enter it, but there’s no install command).

My next attempt was to install the apk bundle on my own device, using USB, and trying the “Share” app function (which permits to share apps between two phones using Bluetooth). Until the last step, it went right, but my app doesn’t appear in the apps list.

The third option I tried was the Play Store. I added the Play Console option to my account and was charged for around 25 € (I thought it was like Apple’s 99 € subscription, necessary). Later, Google asked me to send a picture of my identity card (or passport/driver licence) to prove who I am. At that point, I stopped this attempt, because I don’t think I’m on the right way.
Are these the correct steps and I should continue?

Any hint, please?

Make sure your server is sending the right mime type. For APK files it should be:


goggle developer should be a one time payment.
if you sell something at the play store they get fees. (a few %)

at the device the user must allow install apps from other than google play store.

i installed my apps from ms one drive, google drive, file manager.
the behave would be different from os version.

yes a apk is somehow a zip and the extension should be .apk

in past to sign apps for google play store you just need a self generated keystore file.
to bring up a app into store you need a day for pictures, description, privacy policy, age ratings …

I’ve checked and getting different results.
With the “file” command, the result is “application/zip”. However, by editing the /etc/mime.types file, apk is correctly listed under “application/”. My next problem is to figure out whether “the process that handles download requests” on my server uses the “File” command to inspect the file or reads the mime.types for just the extension. If it does the wrong thing, how to tell it to not rely on the “file” command.

Thank you.

Ah, ok, so I did it right.
Is it normal they then ask me for a picture of my passport?

That’s ok.

They’ll be several persons, so I can’t use such apps.

Thank you.

Your suggestion lead me to a working solution: instead of entering the URL manually in a browser to download the apk file, I made a temporary Xojo web app with just a button, which downloads the file from there. The big advantage (and what led me to consider this way) is that you can specify the mime type: FileToDownload.MimeType=“application/”.


1 Like