Can't get Sound on Ubuntu 14.04 64 bit

Seem to have gstream working according to gstreamer-properties sound test. We use pulse audio in current app but alsamixer controls volume.
Sounds play with mplayer and .wav file is being opened.
Where can I find if an error was output for mSound.Play? I can single step through no prob - just no sound.
How can I figure out where in the chain I’m losing it?
Thanks, John

I don’t know a lot about Linux, but I’ve always found it incredibly difficult.

The GStreamer website doesn’t show explicit support for WAV. I’m probably wrong.

I would use OGG for your sound.

I’m betting theres an issue since Xojo apps are 32 bit

Maybe a shell to Play could do ?

So far spent bunch of time but no joy getting Xojo to do sounds properly on Ubuntu 14.04 64bit even tho gstreamer seems to be running ok. What’s the best way to contact Xojo - I have a full license…

well since we don’t support 64 bit I would guess thats the primary reason

you’d almost have to try a 32 bit release to be sure

Yea that’s a thousand dollar caveat I should have known about! So has anyone run Xojo sound commands successfully on Ubuntu 14.04 32 bit before I tell everyone here we would have to go back to 32 bit to use Xojo, which will be a tough sell.
They clearly state it…

It’s not a thousand dollar caveat. Simply install the necessary 32-bit libraries:

sudo apt-get install libgstreamer0.10-0:i386 gstreamer0.10-plugins-good:i386 gstreamer0.10-pulseaudio:i386

Restart your app and everything will work.

Thank you all for your comments.

The link says Xojo will work with Ubuntu 10.04 and later and 64 bit revs need to install ia32-libs and ia32-libs multiarch which I did. I also installed all the gstreamer libs posted,

Still no joy! I can use:

“gst-launch-0.10 playbin uri=file:///home/myhome/Xojo/Apps/Sounds/Test1.wav”
“gst-launch-0.10 filesrc location=/home/myhome/Xojo/Apps/Sounds/Test1.wav” ! wavparse ! audioconvert ! alsasink"
“gst-launch-0.10 filesrc location=/home/myhome/Xojo/Apps/Sounds/Test1.wav” ! wavparse ! audioconvert ! pulsesink"
“gst-launch-0.10 filesrc location=~/Xojo/Apps/Sounds/Test1.wav” ! wavparse ! audioconvert ! alsasink"

from either the command line or a shell command in Xojo (as long as the shell is running in mode 0-modes 1 & 2 fail to run) and it works, so gstreamer appears to be working fine (also works with my V4L2 video camera src and sink)

Now have installed the …:i386 packages generously suggested by Lars Brennicke, crossed my fingers and, unfortunately, no change.

I do see other folks having issues at the Xojo on Linux, and some have a recommended list of combinations that work for them.

However, the company I work for is trying to stay with one OS and that is Ubuntu 14.04 64 bit. I have everything I need to use Xojo for product development on this platform except sounds!

Very time consuming and frustrating…

Well I have a workaround using global flag for shell “play mysound.wav” in mode 1 using myshell.isrunning and app.doevents looking to see if another sound request has come in or if a kill sound has come in. Modified the sound player demo so can play up to 3 sounds simultaneously. Kludgy but will do what I need, including pan and volume…

Nearly three days before I took Michel Bujardet’s advice and stopped trying to make the Xojo sound work!!!
Thanks Michel.

Hopefully the 64 bit release will restore regular Xojo sound operation…

Glad I could help :slight_smile:

This is really strange. I just downloaded and installed a fresh and unmodified copy of Ubuntu 14.04 64 bit. I then installed Xojo (sound didn’t work yet) and installed the libraries I suggested above. Xojo sound worked.

Could you start Xojo from a terminal, create a new project with this code inside some button:

dim a as folderItem
a = GetOpenFolderItem("")
dim b as sound
b = a.OpenAsSound

Run the app in debug mode, place the terminal window somewhere you can see it, click the button, select your .wav file and look at the terminal. What’s the output?

Is it:
Incompatible version of gstreamer
gstreamer not found

Or something entirely different?

I have another idea: Maybe your .wav file isn’t an uncompressed PCM wav file. You could try installing more gstreamer plugins:

sudo apt-get install gstreamer0.10-plugins-bad:i386

Your command line “gst-launch-0.10” calls use the 64-bit libraries. They obviously work, so you could also see what 64-bit plugins are installed and then install the same packages in the 32-bit version. But I think the package above should be able to play back most .wav files so try that first.

I am very grateful to all who have taken the time to respond and more. I see comments from many other frustrated souls comparing the Linux world to Windows and MAC OS. I have been an application developer for nearly 40 years, and focus my efforts on new product development in either biomedical or entertainment fields, but am definitely NOT a Linux guru. We have several of them here where I work and I take images of their SATA drive OS installs and work from there.
Based on Lars’ comments, it would appear that something was loaded on our internal image of Ubuntu 14.04 64 bit that caused Xojo Sound commands to not function. Michel’s workabout led me to an alternative which may have more playback features, with as yet unknown possible costs.
Besides reaching my goal of a baseline app with full screen mutiple graphic (OpenGL vector and std .bpm .png elements) with mutiple sounds using Xojo, I have found a strong development and support community which makes the leap from Eclipse .cpp world back to a VB-esque RAD world much more comfortable.