Can't get my web app to run on CentOS

Hello Everyone,

For some reason, I simply cannot get my cgi app to run on my Digital Ocean VPS! I’ve done the following:

  • Made sure the app was compiled for Linux
  • Set all permissions to 755, config.cfg to 644 (also tried 755 for config.cfg)
  • Made sure FastCGI was installed and enabled on Apache
  • Made sure to upload my app to the cgi-bin directory

When I access the URL the app should be at, I get the good old “Unable to launch application X on port XXXX”. When I try to run the application from the terminal, I get a 200 OK response followed by the same error message.

I’ve gone through most of the threads in this forum that mention this error, made changes, and still can’t get it to work. Any ideas what might be wrong? BTW, this is on CentOS.


Xojo doesn’t support FastCGI just regular CGI.

Do a ‘ldd BINARYNAME’ to make sure all the libraries have matches. How are you uploading it? Filezilla notoriously uploads as ASCII instead of binary and screws them up.

[quote]For some reason, I simply cannot get my cgi app to run on my Digital Ocean VPS! I’ve done the following:

I was wondering when I was going to see people talking about Digital Ocean.
I haven’t signed up yet myself but I’m wondering why did you choose CentOS and not Ubuntu?

Also don’t forget to install 32 bit libs, anything Xojo requires them.

You may want to zip your app before transfer to make sure it transfers ok. I’m not sure that’s a requirement but I know a lot of things may get screwed up if they aren’t compressed or in a safe format for transferring.

When you get it up and running can you post a link to your app so we can see how fast it runs?

Don’t know if this helps you:

I also have a Centos x64 Vps, used Filezilla to upload the files like you and received the same errors, transfer was set to auto, so I deleted the files and uploaded once more, set the transfer to binary for all files except config.cfg which was uploaded using ascii and then changed file permissions on application to 755 others to 644 and then the app launched.



Looks like my problem wasn’t with the VPS after all but with the version of Real Studio I was running (I’m calling everything Xojo these days, even the older versions). I was compiling using RS2011 and there’s bug in that version that creates a segmentation fault on some versions of Linux. I was running into this. Recompiled using a Xojo proper and everything worked fine. Thanks for all the replies!

USER UNKNOWN: Originally, I chose CentOS because that is what I had used to set up Xojo web apps. Even wrote a blog post on it. But I have since moved over to Ubuntu as it’s what I’m running here at home and the office. Now that I’m using a more recent version of Xojo, things are working very well. Digital Ocean has been amazing. I’ll post a link to the completed when it’s done. Should be a few days.

Thank you Anthony.

It’s good to know D.O. has been amazing. They are my first choice in leasing a VPS (not co-locating).I’ll be glad to see how fast your web edition app runs on their server so thank you for posting the link when it’s ready.

I hope you’ll also share how many concurrent users your web edition app can support and with what D.O. plan and setup you’re using ?
Single core, multiple core load balancing, etc. ?

Which server location is your droplet at?

From what I hear they also have great tutorials on how to load balance and scale which can be applied to Xojo web edition apps.

Have you read any of them or anything helpful to get Xojo web edition apps working well?


Can you give me kind of a step by step setup for setting up a Digitalocean VPS so that it will run the XOJO CGI web app.