Can't get custom image on App Icon

I just built my first pi app to test out something for a forum member and I discovered that I can’t get a .png image to show as the app icon on the Pi Taskbar. I added an image for every size in app.icon in the IDE.

I looked in the examples folder and I couldn’t find a Pi example that used an app icon.

Am I missing something?

Thank you,

It looks like icons need to be configured in the window manager. More info here.

Edit: Just tried that and it keeps opening the .desktop file for editing. On to plan B.

Tanner that link is for creating shortcut links which wasn’t what I am referring to. Did you mean to paste that one?


Yes. It’s actually describing Desktop Launchers, not just shortcuts.

I could be mistaken (my Linux chops area bit rusty) but I think that app icons in Linux are handled exclusively by, and configured separately for, the particular Window Manager that’s in use.

In the LX WM that Raspbian uses, these *.desktop files that the link refers to should appear as app launchers on the desktop, in menus, etc., but they’re not doing so in my install yet.

I doubt embedded icons are supported by any Window Manager in Linux.

For reference, this is what worked for me with an app named PI_Shell. The pi_shell.desktop file is chmod 777, chroot pi:pi. Note this shortcut only worked after changing ownership to root and back. Weird.

pi@rpi:~/Desktop $ cat ./pi_shell.desktop 

[Desktop Entry]
Name=Pi Shell
Comment=Test program

Thanks Tanner I appreciate the help!

Plus <>