Can't build: unable to build chain

While debug runs fine, building this iOS app fails.

Xojo claims that I’m using a self-signed root. I have no clue how and when I would have done that…

Someone else here stumbled over this, but solved it only by chance. The thread is not giving any information which would help me any further.

Where to start?

https://developer.apple.com/forums/thread/131088

Start by following the directions to download the WWDR certificate

1 Like

Thank you for the link!

Is this a new mac?

No, very old one MacBook Pro, Retina, Mid 2012 with macOS 10.15.7 Catalina

Ahh thanks. So it could be that you don’t have the latest xcode ?

Gregs link brought me on the right track on how to install the missing intermediate certificate.
(btw - I have Xcode 12.4 installed).

I had to download the WWDR Certificate from www.apple.com/certificateauthority and then install it through the terminal. Simply doubleclicking it would result in an errormessage from the keychain app.

Now I can build iOS apps with Xojo.

2 Likes

Just a quick&dirty test app, which is making use of MBS plugins for iOS. I enter a search term and the app is querying a remote CubeSQLServer and returns the label of the first matching record.

It looks like we finally have a very easy way to build our inhouse apps!

2 Likes

look cool… i want to something like that too… i want to be able to access a cubesql server somewhere and read some data and show.

what do u need to use for this to happen?

how are you going to deploy in house app???

here is a blog post explaining it:

1 Like

There is also middle way, something called Apple Business account. Where you put on the app store and can then select what customers can get it. (Supposedly).

But it is hard to find much about it. Bellow are things I had bookmarked about it when I last time looked into it:

(note its 2 links it shows it a bit as one)

https://help.apple.com/businessmanager/

1 Like

I run a virtual server with cubesql installed on it.

Then I use Xojo 2020 r2.1 with the most recent MBS plugins (including MBS Sql plugin), which includes all cubesql libraries.

Then I have a developer account with Apple (99.- / year) from where I get the necessary certificates, plus Xcode for distribution to some devices.

Code example:

https://docs.xojo.com/UserGuide:iOS_Device_Deployment

1 Like

thanks for the links… this is something i want to explore (when i have the time)

Despite having a valid Apple WWDR CA certificate that was good until 2023 I followed the above help and installed a new Apple WWDR CA certificate. That worked. Then I created and downloaded new iOS Development Certificate and new mobile provisioning profile. Same error message. Checking I find that Keychain Access shows the new iOS Development Certificate as not trusted. So therein lies the problem. Not sure what to do next.

I did a blog post about this and the order that things need to be done in to be successful.

2 Likes

So I found the secret. Apple have released a large number of Apple WWDR CA certificate versions (the so called intermediate certificate). I found an Apple document that says use the one the expires in 2030. That is the one with G3 at the end of the name (they go up to G6). I had previously assumed I should use the latest G6. Wrong.
I just downloaded the G3 version certificate, created and downloaded a new iOS Development Certificate successfully, created a new profile and Xojo built my app.
By the way the certificate installed just by double-clicking it for me.
Now on to the next issue.

1 Like
Forum for Xojo Programming Language and IDE. Copyright © 2021 Xojo, Inc.