Can't Build Project Now (Could Before)

I must be missing something that’s staring me right in the face, but I tried to build the project I’ve been working on for months now (last successful build I tried was late last year) and the following occurs now:

  1. Build progress dialog window opens
  2. Looks like lots of stuff being compiled from what shows in the dialog window
  3. Abruptly stops after ~ 10 seconds and gives no error message (or any other message of any kind … simply returns me to the IDE)
  4. It creates the Build Folder with a folder inside it called “Windows” … which is completely empty … and no other content to be found

The only thing that has changed since the last successful build I did was the addition of some 3rd party plug-ins (e.g., Elastic Window, Einhugur Calendar Control, MBS, etc.). I have very carefully made sure (triple checked) that the plug-ins folder has all of the “registered versions” of everything (no trials) needed and I have the serial numbers for the MBS stuff in the App.Open event like I should.

I have the Build Settings with “This Computer” checked (no others) and am using Windows 7 Ultimate, 64-bit.

I even tried the same project on my laptop and get the exact same result. What am I missing??? I’m supposed to have a build done for my customer by tomorrow, so needless to say, I’m a tad on the nervous side at the moment.

Thanks in advance for your tiime,
… Don

Oh, and I noticed I left this little tidbit out that might help … I’m using XOJO Version 2013 release 4.1

The first thing I’d try is remove any plugins that you don’t need. For instance, if you’re not using the Oracle plugin, remove it. I usually make a folder called “Plugins (Disabled)” and move them in case I ever need them again. But I’d bet there’s a lot of pieces of the MBS library that you don’t need.

Also, make sure you’re using the plugins that have the .xojo_plugin extension.

It sounds like maybe you have a #pragma disableBoundsChecking or #pragma NilObjectChecking false
Often calling on a nil picture will crash hard if nilobject checking is off…

Thanks, Greg … I removed anything not being used by the application from the plug-ins … I’m afraid that made it worse … now, it has all the same symptoms (e.g., looks like it’s building) but doesn’t even create the builds folder

Jim, how do I check that?

Jim … I did a global search of the project for any #pragma statements and found the following:

#pragma BackgroundTasks False … used in a method I call to reverse a string’s contents (but that was already there when I did the last successful build several months ago

#pragma DisableBoundsChecking … used by the Elastic Window classes

I need the Elastic Windows mightily in this project. To remove the plug-in, I’d have to go back and change a BUNCH of supers … is there another way of checking if that’s the culprit?

Well, I believe I can rule the #pragma commands out as the problem … I commented them all out and the same thing happens when I attempt a build … lights are flashing, gates are down … train ain’t coming … it results in an empty build folder with the “Windows” folder inside it which is completely empty.

Does it Run from Xojo?

Troubleshooting ideas:

  • Install DebugView and check if the console has any messages regarding this
  • Try a different user account that has never had Xojo installed
  • Try Xojo 2013 r3.3

#pragma should never cause a compilation error

a run time error maybe as you don’t get the various checks but never a compilation error

Hi Paul! Thanks for responding.

Yes, it runs fine with the Debugger … it’s only when I try to build that things go south. I have narrowed it down over the past 30 minutes by going thru every single Xojo version I created and saved over the past 30 days to see where something changed. It appears to a set of classes I purchased from piDog Software using “TheBigUndo”. Originally after having bought them, I integrated them into the project but found a “glitch” when they tried to process radio button actions in a container that caused a program crash. Working together with the creator (Jim @ piDog), he found what he felt was the problem, fixed it, and sent a new version of the classes to me to try. It indeed solved the problem with the radio button actions. However, now I see where my build problem happened with the first version of the program where I introduced the “revised” classes. Not sure what he might have done, but I just sent a frantic email to him. BTW … I have found Jim to be a really committed and passionate guy who cares a great deal about making his customers happy (not to mention the fact that his software saved me a huge amount of time in writing my own UNDO/REDO code) … so, here’s hoping!

You have any ideas what might have happened?

… Don

No. My first guess would be that this is a cache problem of some kind, but that seems unlikely for a Build.

Anyway, do check the console to see if anything useful appears there. A new account allows you to try without having any possible pre-existing caches.

OK … admits ignorance … how do I do that?

OK, Paul … thanks for the direction. I did what you suggested and got the following:

[9400] pre build
[9400] Command “BuildApp” handled by Window “Xojo - [CaseDBM_v022714_0855.xojo_binary_project]”
[3020] 10912 0000000000000000 ENTER: DllCanUnloadNow
[3020] 10912 0000000000000000 LEAVE: DllCanUnloadNow
[3020] 10992 0000000000000000 ENTER: DllCanUnloadNow
[3020] 10992 0000000000000000 LEAVE: DllCanUnloadNow

Not sure if that’s telling me anything

Nothing useful - no

Well, it’s solved now. After I sent him an email with the problem, Jim from piDog Software checked it out, found the issue, corrected and sent me the revised classes all in under an hour. Two things I learned from this experience:

  1. There’s a lot of variables that impact a build and I have a world of learning to go before I begin to grasp it all (but I’m having a ball doing it :slight_smile: )
  2. I’m even more impressed than before (and that was pretty impressed to begin with) with Jim at piDog Software. Wow! What commitment to satisfaction. For any of you that haven’t seen his “TheBigUndo”, you oughta check it out … very cool!

Not sure how I mark this thread as “Solved” … and last, but not least, thanks to all who responded. Your time is much appreciated!

… Don

I’d be REALLY curious as to what in the big undo causes a compile to stop
That seems really unusual


I wouldn’t think Jim would have any problem sharing that info with you. Do you need his email or contact info?

… Don

Click the “checkmark” that appears in the post when you hover over it to choose a post as the “answer”.