Cannot run from IDE - wrong URL - 2020 R1.1, R1.2

Doh! Well it’s late in the day for me and I think my brain gave up after scrolling trough this thread, especially since we are now in 2021 and I can’t convert my Web apps to Web 2.0 because reasons. I’ll go crawl back into my hole now.

drags knuckles as he slowly slinks off into the shadows

1 Like

It’s okay, numbers are hard!

2 Likes

hello
when one changes the register, it works fine, but i every 2 or 3 days it resets it self again to the one that does not allow xojo webapp run.
Is there a way to fixate the register to the one that works?
regards

Because of that, I ended up creating a shortcut in my browsers with http://127.0.0.1:8080/. It is quick and easy, and permanent. Change it as required for https or a different port. I use it when I go back to 2019 R3.1 for web 1 maintenance work.

Did your primary browser get updated in the last 24 hrs? Xojo has had this problem from time to time on Windows and it almost always turned out to be an issue that was solved by another browser update.

this is a really old issue No problem with recent Xojo versions.

altering the registry to leave a vulnerability open is not wise. Just ad a shortcut in browser to the debug URL

1 Like

thanks, for a while i did so
but, RUN should just work (for me)
still, what i don´t understand is what programa or process changes back the register?

It’s one of your browsers making this change. I don’t remember off the top of my head, but the problem was corrected in newer versions of Xojo.

It was fixed in 2020r2 :slight_smile:

It must be the antivirus or any other sowftware preventing security risks. again, changing the registry makes your computer vulnerable

Thank you