Cannot run from IDE - wrong URL - 2020 R1.1, R1.2

So, when I try to run my test application from the IDE on Windows 10, I get a malformed URL (tried several browsers). The browser shows

http://%22http//127.0.0.1:8080/%22

  • I de-installed Xojo 2020 R1.1 and installed 2020 R1.2
  • I cleared the cache in /user/appdata/roaming/Xojo *
  • I rebooted Windows

The interesting thing is that yesterday, all was as well as one could expect with web 2.0. None of these steps fixed the issue. I did work on creating a new bootstrap (oh how much do I hate that thing! - but if you can’t beat them, join them) theme. could that be an issue?

What could I try next?

I remember someone else reported this, also using Windows 10. I think the poster had other issues and did a Windows 10 reinstall. Of course, this is something that is extreme to fix that.

Found the FC: feedback://showreport?report_id=61634

Because you are the second person reporting this, it may be hard to find a solution.

Restart pc may fix it

I was afraid of that… I have this side project to ramp-up my abilities on Linux. My database servers are now on Linux. Perhaps this will hasten my desktop transition to Linux as well.

Thank you for the response Alberto!

tried that already.

Thanks anyway!

Try to set the build settings debugport to 9000

I had already tried that (8088). Tried again with different ports including 9000 as you suggested. The behavior is the same. I can also confirm that this is not specific to that one project, I tried with a fresh new project just to eliminate that possibility, with the same behavior.

Well. I think Xojo was a bit quick in sweeping 61634 under the rug. Everything else works just fine on the computer. There has to be something broken in Xojo, that happens with a specific sequence of events. I am trying to figure what the steps were before the problem occured. Not easy.

Ok this seems off, i havn’t seen this behavior. Which windows version do you use?

Windows 10 2004 fully patched.

  • disabled the antivirus just in case. No cigar.

well, well… I just installed Xojo on a new computer. Same exact problem. It is not related to my computer. 2 different compuyters have the issue.

Now, since Xojo did not change overnight, I will now turn my attention to patches that could have been installed overnight.

Well, the creator of the Case said that they can close the problem, without more information or steps to reproduce it, it will be hard to fix.

Let’s see, things in common:

  • using Windows 10 2004
  • it worked before and then this started to happen

Questions:

  • have your Windows 10 installed an update recently?
  • have your Windows 10 got a new Edge version?
  • can you change your default browser to Firefox/Chrome/Safari/Opera or other and see if the same happens?

I hope you can find more information and a way to reproduce it. Good luck.

That’s good information. If is simple as install Windows 10 2004, fully update it, install Xojo and you will see the problem, then I’m sure that Xojo can see what is going on and take the steps needed to work around that Windows change.

Alberto, I thionk that the update track is a good one. As I indicated, I have 2 different computers showing the same issue. Both were on last night.

The issue happens with Edge Chromium, Chrome and Vivaldi - hum… could it be an update to the chromium engine? - I will test Firefox.

Bingo! Firefox is OK.

All the browsers using the chromium engine fail this morning. There was indeed an update to Edge Chromium installed last night. Chrome and Vivaldi use the same base engine. Thanks for placing me on the right track Alberto!

1 Like

This almost seems like there might be an errant protocol handler installed on these systems.

Have you tried disabling extensions?

I don’t have any extension installed on Edge Chromium. I willm try that on the other chromium based browsers.

Now you can file a bug report with that information. Xojo only needs to have the latest Windows 10 2004 with Edge installed to see the problem and decide what they can do about it.

It will be a growing problem as users update Windows 10.