Cannot connect to remote debugger (non admin user)

Xojo2013r3 on Windows 7 Professional SP1

We have installed Xojo on a number of machines in a classroom environment. For obvious reasons we dont want the students to have administrator rights over the PC.

When running as a Domain Admin user everything works. When running as a student we open a project (any project) and click run. We then get the error ‘Cannot connect to remote debugger’.

I have tried the following:
Grant full control over the xojo folder and its entire contents
Grant full control over c:\temp
manually Run the debugger console from the xojo\extras\remote debugger console\windows folder
(temp) adding the user account to the local administrators group.
Disabling the firewall (again temp)
None of the above has worked.

I am frankly stumped. What am I missing here?


I have now discovered that if the project is saved locally (C:\TEMP) then it runs successfully as a non administrator user.
All users have their my documents mapped to a central server and drive Z: is also connected to this home directory.
Even with full control over the share and the files/folders if the project is saved in this location it errors.
When the program runs I see a process called DebugMy Application and it creates a folder called DebugMy Application in the same folder as the project. Under this there is an executable (DebugMy Application.exe) and a subfolder (DebugMy Application Libs) with three DLL files in it.

On a shared drive this folder structure is not created.

Do students have any privileges to create dirs etc on the shared drive ?
Sound like that’s might be failing so the Run fails

Students have full control over the share and the drive. I have looked at the group policies for folder restrictions and cannot see anything obvious.

I ran into an issue like this when working on the Remote Debuggers last year. On the student machines, they may not have write permission to the default download directory. What I did was make a folder on the Desktop named “RDS” and told the debugger to use that.